The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Perl became crazy in my server

Discussion in 'General Discussion' started by mapg, Feb 23, 2009.

  1. mapg

    mapg Member

    Joined:
    Dec 9, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I got a box with Centos OS 5.2 and perl 5.8.8 (libwww 5.824) and I get strange error messages without any reasonable cause with the same scripts that I run in other server with Centos 4.7, Perl 5.8.8 (libwww 5.810)

    I do not know if the cause is different libwww, but I get errors like this in the 5.8.8 (libwww 5.824) using a simple MIME:: Base64 call.

    There are errors in many more Perl modules and this is happening randomly, no all time.

    Have a look ...
    Code:
    Unrecognized character \\x7F at /usr/lib/perl5/5.8.8/warnings.pm line 482.
    Compilation failed in require at /usr/lib/perl5/5.8.8/warnings/register.pm line 24.
    Compilation failed in require at /usr/lib/perl5/5.8.8/vars.pm line 7.
    BEGIN failed--compilation aborted at /usr/lib/perl5/5.8.8/vars.pm line 7.
    Compilation failed in require at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/MIME/Base64.pm line 6.
    BEGIN failed--compilation aborted at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/MIME/Base64.pm line 6.
    Compilation failed in require at index.cgi line 6.
    BEGIN failed--compilation aborted at index.cgi line 6.
    What can I do, to force a reinstall? Is this going to fix Perl?

    I saw a Perl 5.8.8 published in Cpanel very recently, past February 17.

    Maybe they found that Perl was working wronly and changed something. I do not know, but I get errors with a simple usage of common Perl modules

    Please, I need help about this.

    Thank you very much in advance.

    Mapg
     
Loading...

Share This Page