The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

perl broke on FreeBSD 5.1

Discussion in 'General Discussion' started by 10101, Jun 27, 2004.

  1. 10101

    10101 Well-Known Member

    Joined:
    Sep 4, 2003
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    My server is Freebsd 5.1 and perl is not working at all on the server, it keeps giving internal server errors on simple test scripts.

    Does anyone know how I can fix perl?
     
  2. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    What does the error log say for the domain your testing the scripts on?
     
  3. 10101

    10101 Well-Known Member

    Joined:
    Sep 4, 2003
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    Its showing "Premature end of script headers"
     
  4. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Does your script have the right path to perl?

    #!/usr/bin/perl

    or

    #!/usr/local/bin/perl

    Did you upload in ASCII mode (text)?
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Also,

    Make sure that your cg-bin directory and any subdirectory within that that contains scripts, is CHMOD 755.
     
  6. 10101

    10101 Well-Known Member

    Joined:
    Sep 4, 2003
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    16
    It seems like the problem is that they only execute inside the cgi-bin, any way to fix this?
     
Loading...

Share This Page