Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Perl/CGI Problem

Discussion in 'General Discussion' started by ccgale1979, Jul 10, 2012.

  1. ccgale1979

    ccgale1979 Registered

    Joined:
    Jul 10, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi all, sorry if posted in wrong section, not sure where this should go...

    Try as I may I cannot get any per scripts to run on my server. I have tried them with various permissions, inside and outside the cgi-bin folder but each time I get a 501 Internal Server Error message.

    Please see the following urls as an example - Removed - and - Removed - and - Removed -

    my error logs pulled from ...apache/logs/ are thus

    Code:
    [2012-07-10 17:45:34]: uid: (501/nuclear) gid: (501/nuclear) cmd: 1.pl
    [2012-07-10 17:45:53]: uid: (501/nuclear) gid: (501/nuclear) cmd: 1.pl
    [2012-07-10 17:46:09]: uid: (501/nuclear) gid: (501/nuclear) cmd: 1.pl
    [2012-07-10 17:46:09]: file has no execute permission: (/home/nuclear/public_html/domain.net/1.pl)
    [2012-07-10 17:46:27]: uid: (501/nuclear) gid: (501/nuclear) cmd: 1.pl
    [2012-07-10 17:46:27]: file has no execute permission: (/home/nuclear/public_html/domain.net/1.pl)
    [2012-07-10 17:46:55]: uid: (501/nuclear) gid: (501/nuclear) cmd: manage.pl
    [2012-07-10 17:47:18]: uid: (501/nuclear) gid: (501/nuclear) cmd: manage.pl
    [2012-07-10 17:48:01]: uid: (501/nuclear) gid: (501/nuclear) cmd: 1.pl
    [2012-07-10 17:48:01]: file has no execute permission: (/home/nuclear/public_html/domain.net/1.pl)
    [2012-07-10 17:48:02]: uid: (501/nuclear) gid: (501/nuclear) cmd: manage.pl
    [2012-07-10 17:48:35]: uid: (501/nuclear) gid: (501/nuclear) cmd: 1.pl
    [2012-07-10 17:48:35]: file has no execute permission: (/home/nuclear/public_html/domain.net/1.pl)
    [2012-07-10 17:50:18]: uid: (501/nuclear) gid: (501/nuclear) cmd: manage.pl
    [2012-07-10 18:01:13]: uid: (501/nuclear) gid: (501/nuclear) cmd: whmredirect.cgi
    [2012-07-10 18:01:47]: uid: (501/nuclear) gid: (501/nuclear) cmd: 1.pl
    [2012-07-10 18:02:14]: uid: (501/nuclear) gid: (501/nuclear) cmd: 1.pl
    I fixed the permissions problem, had a file set as 644 instead of 755 but it hasn't made any difference.

    I have played about in whm with Configure PHP and SuExec and every combination I try continues to yield no success. My current config is:

    PHP:
    php.conf updated to:

    # This file was automatically generated by the Cpanel PHP Configuration system
    # If you wish to change the way PHP is being handled by Apache on your system,
    # use the /usr/local/cpanel/bin/rebuild_phpconf script or the WHM interface.
    #
    # Manual edits of this file will be lost when Apache is updated.


    # CGI configuration for PHP5
    Action application/x-httpd-php5 /cgi-sys/php5
    AddType application
    /x-httpd-php5 .php5 .php4 .php .php3 .php2 .phtml

    # End of autogenerated PHP configuration.


    Updating user configurable PHP settings.
    [
    inforecursion depth is set to2
    Restarting Apache

    If anyone could offer an opinion on this I would be most grateful. I have been searching the forum and the web for days but still not solution. My server is a dedicated server and cpanel is not a supported panel so they cannot help.


    Many thanks

    Carl
     
    #1 ccgale1979, Jul 10, 2012
    Last edited by a moderator: Jul 23, 2014
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,608
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Please stat the file and let us see the output:

    Code:
    stat 1.pl
    It definitely needs to be 755 file permissions (or chmod +x 1.pl after you've created it). I don't know that user's specific UID and GID, so stating will give us all that information.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice