The Community Forums

Interact with an entire community of cPanel & WHM users.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

perl error when upgrading from 11.44 to 11.46

Discussion in 'General Discussion' started by Venomous21, Nov 24, 2014.

  1. Venomous21

    Venomous21 Well-Known Member

    Joined:
    Jun 28, 2012
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Hello,

    Was upgrading a server from 11.44.1.23 to 11.46.0.17 and received an email from the server:

    Subject: Cron <root@asdf> /usr/bin/test -x /usr/local/cpanel/bin/tail-check && /usr/local/cpanel/bin/tail-check

    Body of Email: /usr/local/cpanel/bin/tail-check: error while loading shared libraries: /usr/local/cpanel/perl/libperl.so: cannot open shared object file: No such file or directory

    How should I investigate and resolve this issue? Everything appears to be functioning normally so far.

    Thank you.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  3. Venomous21

    Venomous21 Well-Known Member

    Joined:
    Jun 28, 2012
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Michael,

    Hello, I have not yet opened a ticket but am hoping to resolve this issue without doing so if possible.

    I notice the 11.46.1.1 changelogs mention:

    Fixed case 124297: Update cpanel-perl-514-Storable to 2.45-2.cp1146.

    Would this possibly resolve this issue if I try updating? Or is there any recommended way I can re-install perl to fix this issue?

    Would you like this info?
    # ls -alh /usr/bin/perl
    # ls -alh /usr/local/bin/perl

    Should I /scripts/checkperlmodules --full ?

    OR?

    /scripts/fixperl

    or a complete perl reinstall (assuming this is correct syntax based on another post)?

    - Removed -

    Thank you.
     
    #3 Venomous21, Dec 3, 2014
    Last edited by a moderator: Dec 11, 2014
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    That method of reinstalling Perl is no longer valid. I suggest opening a support ticket so we can take a closer look and determine the cause of the problem.

    Thank you.
     
  5. Venomous21

    Venomous21 Well-Known Member

    Joined:
    Jun 28, 2012
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Michael,

    I am always hesitant to allow people I don't personally know to access my servers, even though I know cpanel is a trusted company and we use your software. If you could post the exact logs or information you need, I would be happy to post it here or send it to you in PM. I have not received any additional messages about perl at this time.

    I'd like to run easy apache. I assume not but will this perl issue affect my ability to successfully run easy apache? I assume no but want to double check before doing so.

    Thank you.
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,450
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Forcing an update should be fine I would think. Post back if you note any errors in the update log.
     
  7. Venomous21

    Venomous21 Well-Known Member

    Joined:
    Jun 28, 2012
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    I'd like an official response if possible to my last reply. I'd like to run easyapache on this server and also would be happy to provide any logs or information needed about the perl issue. I notice 11.46.2.0 hasn't been released yet but mentions:

    [security] Fixed case 129569: Upgrade cpanel-ImageMagick and perl modules to 6.9.0.

    Would it possibly uninstall and re-install 6.9.0 for all perl modules possibly correcting this problem or this only imagemagick specific? Thank you.
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    It's not likely to correct the issue that you have reported. You can choose to not provide us with access to the server when opening a support ticket if you just want to provide us logs instead of us logging in directly.

    Thank you.
     
Loading...

Share This Page