Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Perl & freebsd installtion error

Discussion in 'General Discussion' started by gloverkarl, Jul 2, 2005.

  1. gloverkarl

    gloverkarl Well-Known Member

    Joined:
    Feb 29, 2004
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    156
    Installer Version 10.3.1


    ELF binary type "0" not known.
    ./futex-test: 1: Syntax error: "(" unexpected
    strings: '/boot/System.map*': No such file
    Fatal! perl must be installed before proceeding


    After getting the cPanel latest script to install i get the above error, i have installed perl and when using pkg_add -r perl i get;

    Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-5.4-release/Latest/perl.tbz... Done.
    pkg_add: package 'perl-5.6.2_2' or its older version already installed.

    If anyone can help with the following it would be very greatful.

    Regards,
    Karl Glover.
     
  2. eger

    eger Well-Known Member

    Joined:
    Feb 28, 2003
    Messages:
    128
    Likes Received:
    0
    Trophy Points:
    166
    having same error on my FreeBSD 5.4-RELEASE install. Going to try setting up the linux compat to see if that is required... i sure hope that is not the case though.
     
  3. Webjunkie

    Webjunkie Active Member
    PartnerNOC

    Joined:
    May 1, 2003
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    156
    I saw this same error, but everything installed without any problems.
     
  4. gloverkarl

    gloverkarl Well-Known Member

    Joined:
    Feb 29, 2004
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    156
    moo

    Okay, i managed to fix it all i did was reinstalled the latest version of perl, linux-base and rebooted seemed to work fine.

    Not much to go on but hope it helps,

    Regards,
    Karl Glover
     
  5. eger

    eger Well-Known Member

    Joined:
    Feb 28, 2003
    Messages:
    128
    Likes Received:
    0
    Trophy Points:
    166
    installing perl5.8 from port worked. looks like it requires perl5.8 to get going. both versions can be installed fine.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice