The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Perl module Storable v 2.39_01 doesn't work properly

Discussion in 'General Discussion' started by Lor, Dec 5, 2012.

  1. Lor

    Lor Well-Known Member

    Joined:
    Apr 29, 2005
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    I found today my server have installed Storage v 2.39_01, instead just 2.39
    I had several issues because Storage didn't work properly.

    After I reinstall Storage v 2.39 everything fine.

    What's the v 2.39_01 is?
     
  2. KostonConsulting

    KostonConsulting Well-Known Member

    Joined:
    Jun 17, 2010
    Messages:
    255
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    San Francisco, CA
    cPanel Access Level:
    Root Administrator

    Good question. I believe you are referencing the Storable module (http://search.cpan.org/~ams/Storable-2.39/)?

    There is no Storable 2.39_01 so that may be a version of Storable that cPanel has customized. What version of cPanel are you on?

    Please post the output of these commands so we can have more information about what version you are running:
    Code:
    cat /usr/local/cpanel/version;
    grep CPANEL= /etc/cpupdate.conf
    
     
  3. Lor

    Lor Well-Known Member

    Joined:
    Apr 29, 2005
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    11.34.0.11
    CPANEL=release

    How to stop cpanel updating the perl module?

    Today again my websites didn't work because the version 2.39_01 !!!

    Ok. I switch to manual update for cPanel and reinstall Storable to v2.39

    FYI:
    Storable(v2.39_01) have problem with: Storable::retrieve, I found it in Algorithm::NaiveBayes.
    Storable didn't retrieve the same hash as saved in method '_load_model_class' >> see NaiveBayes.pm
     
    #3 Lor, Dec 6, 2012
    Last edited: Dec 7, 2012
  4. Lor

    Lor Well-Known Member

    Joined:
    Apr 29, 2005
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Ok. I setup yesterday manual update for cPanel, but today I see again the version of Storable 2.39_01

    How I can prevent cPanel from install the version what not working properly?
     
  5. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,480
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  6. Lor

    Lor Well-Known Member

    Joined:
    Apr 29, 2005
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    #6 Lor, Dec 7, 2012
    Last edited: Dec 7, 2012
  7. CitizenK

    CitizenK Well-Known Member

    Joined:
    Jun 5, 2012
    Messages:
    64
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    On The Road
    cPanel Access Level:
    Root Administrator
    Hello,

    There have been a few issues recently with the Storable perl module recently. Following the instructions below will install Storable (currently 2.39) on your system. If you ran these commands in the past, please re-run them since we have recently updated our mirrors to help resolve these issues.
    Code:
    /scripts/perlinstaller --force Storable
    /scripts/upcp --force
    
    Thanks,
     
    #7 CitizenK, Dec 8, 2012
    Last edited: Dec 8, 2012
Loading...

Share This Page