The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Perl problems - Cpanel not working

Discussion in 'General Discussion' started by jimfurtado, Feb 25, 2012.

  1. jimfurtado

    jimfurtado Member

    Joined:
    Jan 2, 2004
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Somerset, Massachusetts, United States
    CentOS 6.2, installed 64-bit.

    I was having a problem getting Logwatch working on the server as perl could not recognize that a dependency was installed. Additionally I was having problems getting GD to install correctly using Cpanel's easyapache. Threads at Cpanel.net suggested a possible fix was reinstalling Perl. I reinstalled Perl using the suggested Cpanel source at http://layer2.cpanel.net/perl588installer.tar.gz.

    Since reinstalling Cpanel does not work and I get errors like the following: /scripts/checkperlmodules --full --force
    Can't locate XSLoader.pm in @INC (@INC contains: /usr/local/cpanel /usr/local/lib/perl5/5.8.8/x86_64-linux /usr/local/lib/perl5/5.8.8 /usr/local/lib/perl5/site_perl/5.8.8/x86_64-linux /usr/local/lib/perl5/site_perl/5.8.8 /usr/local/lib/perl5/site_perl .) at /usr/local/lib/perl5/5.8.8/x86_64-linux/Fcntl.pm line 61.
    BEGIN failed--compilation aborted at /usr/local/lib/perl5/5.8.8/x86_64-linux/Fcntl.pm line 61.
    Compilation failed in require at /usr/local/cpanel/Cpanel/SafeFile.pm line 14.
    BEGIN failed--compilation aborted at /usr/local/cpanel/Cpanel/SafeFile.pm line 14.
    Compilation failed in require at /usr/local/cpanel/Cpanel/Config/LoadCpConf.pm line 8.
    BEGIN failed--compilation aborted at /usr/local/cpanel/Cpanel/Config/LoadCpConf.pm line 8.
    Compilation failed in require at /scripts/checkperlmodules line 11.
    BEGIN failed--compilation aborted at /scripts/checkperlmodules line 11.

    After some research, I find that Centos 6.2 uses Perl 5.10.1, so it seems as though the OS is confused about the right Perl to use.

    When I do perl -v, I get:
    This is perl, v5.8.8 built for x86_64-linux

    When I do rpm -qa perl, I get:
    perl-5.10.1-119.el6_1.1.x86_64

    Cpanel is no longer working. I can neither update using upcp or access WHM.

    Can you suggest a fix?
     
    #1 jimfurtado, Feb 25, 2012
    Last edited: Feb 25, 2012
  2. hoststop

    hoststop Well-Known Member

    Joined:
    Dec 6, 2011
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Bolton, UK
    cPanel Access Level:
    Root Administrator
    Set cPanel to stable and perform a upcp. Performing a upcp at Stable sorted issues for me though.
     
  3. wizzy420

    wizzy420 Well-Known Member

    Joined:
    Nov 13, 2007
    Messages:
    125
    Likes Received:
    2
    Trophy Points:
    18
    Same for me.

    Newer CentOS 6.2 installs are working

    Older CentOS 6.x install just all the sudden up and started going crack out crazy on Perl.

    Lots on "expect failed" and "all available perl module install methods have failed"

    with tailwatchd, anything cpanel/perl dying left and right.
     
  4. wizzy420

    wizzy420 Well-Known Member

    Joined:
    Nov 13, 2007
    Messages:
    125
    Likes Received:
    2
    Trophy Points:
    18
    Tried d/l perl installer & running, tried a force upgrade ... currently on RELEASE

    CentOS 6.2, 64-bit
     
  5. wizzy420

    wizzy420 Well-Known Member

    Joined:
    Nov 13, 2007
    Messages:
    125
    Likes Received:
    2
    Trophy Points:
    18
    Also started getting lots of stuff like this in the logs. Doesn't appear to be server/cpu/memory related as it's limited to a single VPS. And it's all perl related stuff that is dying, nothing else.

    leechprotect[2713] trap invalid opcode ip:7fc44fcd53b8 sp:7fffa41a9c40 error:0 in DBI.so[7fc44fcc5000+19000]
    tailwatchd[3333] trap invalid opcode ip:7f75898e63b8 sp:7fff6df0f6e0 error:0 in DBI.so[7f75898d6000+19000]
    perl[3439] trap invalid opcode ip:7fda950ceed0 sp:7fff3fe562f0 error:0 in vxs.so[7fda950cc000+6000]
    realperlinstall[3440] trap invalid opcode ip:7f4adf799ed0 sp:7fffbbb76610 error:0 in vxs.so[7f4adf797000+6000]
    mysqluserstore[3513] trap invalid opcode ip:7f013d50f3b8 sp:7fff28720070 error:0 in DBI.so[7f013d4ff000+19000]
    update_db_cache[3515] trap invalid opcode ip:7f3420f563b8 sp:7fff79238730 error:0 in DBI.so[7f3420f46000+19000]
    perl[4277] trap invalid opcode ip:7fdeccc55ed0 sp:7fff79277aa0 error:0 in vxs.so[7fdeccc53000+6000]
    realperlinstall[4279] trap invalid opcode ip:7f1078271ed0 sp:7fffcfec4250 error:0 in vxs.so[7f107826f000+6000]
    cpcpan_check_in[4293] trap invalid opcode ip:7f1aaf9e2ed0 sp:7fff302cc7c0 error:0 in vxs.so[7f1aaf9e0000+6000]
    cpcpan_check_in[4347] trap invalid opcode ip:7fda195fb1a2 sp:7fff53584190 error:0 in SSLeay.so[7fda195c1000+4f000]
    cpcpan_check_in[4349] trap invalid opcode ip:7effe4a88d8f sp:7fff522e7020 error:0 in SSLeay.so[7effe4a4b000+4f000]
    cpcpan_check_in[4355] trap invalid opcode ip:7f612201b1a2 sp:7fffe62f6730 error:0 in SSLeay.so[7f6121fe1000+4f000]
    cpcpan_check_in[4412] trap invalid opcode ip:7f40e8754ed0 sp:7fff90beb5a0 error:0 in vxs.so[7f40e8752000+6000]
    cpcpan_check_in[4418] trap invalid opcode ip:7fe39cff5ed0 sp:7fff42f6edb0 error:0 in vxs.so[7fe39cff3000+6000]
    cpcpan_check_in[4419] trap invalid opcode ip:7f69bf93ced0 sp:7fff4fe12b40 error:0 in vxs.so[7f69bf93a000+6000]
    cpcpan_check_in[4431] trap invalid opcode ip:7f30ed4881a2 sp:7fff0b6a6c70 error:0 in SSLeay.so[7f30ed44e000+4f000]
    realperlinstall[4467] trap invalid opcode ip:7fbd13e53ed0 sp:7fffbdcb0140 error:0 in vxs.so[7fbd13e51000+6000]
    cpcpan_check_in[4474] trap invalid opcode ip:7f32c16dd1a2 sp:7fffd05156b0 error:0 in SSLeay.so[7f32c16a3000+4f000]
    cpcpan_check_in[4475] trap invalid opcode ip:7f8b1806cd8f sp:7fff3f7189a0 error:0 in SSLeay.so[7f8b1802f000+4f000]
    perl[4476] trap invalid opcode ip:7f03bf72bed0 sp:7fff3a6d89e0 error:0 in vxs.so[7f03bf729000+6000]
    realperlinstall[4477] trap invalid opcode ip:7fd51d186ed0 sp:7fff1c9b8700 error:0 in vxs.so[7fd51d184000+6000]
    cpcpan_check_in[4484] trap invalid opcode ip:7f14524dbd8f sp:7fffdeacc0e0 error:0 in SSLeay.so[7f145249e000+4f000]
    cpcpan_check_in[4485] trap invalid opcode ip:7fcdb81471a2 sp:7fff875cd000 error:0 in SSLeay.so[7fcdb810d000+4f000]
    perl[4486] trap invalid opcode ip:7f9200eeded0 sp:7fff2a77ea70 error:0 in vxs.so[7f9200eeb000+6000]
    realperlinstall[4487] trap invalid opcode ip:7f45dee62ed0 sp:7fff403d7920 error:0 in vxs.so[7f45dee60000+6000]
    cpcpan_check_in[4495] trap invalid opcode ip:7fd2fd6741a2 sp:7fffadb1c840 error:0 in SSLeay.so[7fd2fd63a000+4f000]
    realperlinstall[4498] trap invalid opcode ip:7faf477c6ed0 sp:7fffeba987b0 error:0 in vxs.so[7faf477c4000+6000]
    cpcpan_check_in[4506] trap invalid opcode ip:7ff56bd4bed0 sp:7fff4e16c660 error:0 in vxs.so[7ff56bd49000+6000]
    cpcpan_check_in[4507] trap invalid opcode ip:7f6ed170ded0 sp:7fff6d6225a0 error:0 in vxs.so[7f6ed170b000+6000]
    perl[4508] trap invalid opcode ip:7f43f0695ed0 sp:7fff1ac78de0 error:0 in vxs.so[7f43f0693000+6000]
    realperlinstall[4509] trap invalid opcode ip:7fbe2d9b6ed0 sp:7fff17e57790 error:0 in vxs.so[7fbe2d9b4000+6000]
    cpcpan_check_in[4517] trap invalid opcode ip:7f2bc8d70ed0 sp:7fff4e7cf740 error:0 in vxs.so[7f2bc8d6e000+6000]
    cpcpan_check_in[4518] trap invalid opcode ip:7fcc5d840ed0 sp:7fffc9e80800 error:0 in vxs.so[7fcc5d83e000+6000]
    perl[4519] trap invalid opcode ip:7ffa853b1ed0 sp:7fffac4889c0 error:0 in vxs.so[7ffa853af000+6000]
    realperlinstall[4530] trap invalid opcode ip:7f4a44553ed0 sp:7fff5b2c1a50 error:0 in vxs.so[7f4a44551000+6000]
    realperlinstall[4532] trap invalid opcode ip:7f4a44553ed0 sp:7fff5b2c1a50 error:0 in vxs.so[7f4a44551000+6000]
    cpcpan_check_in[4534] trap invalid opcode ip:7f2065197ed0 sp:7fff5ffc6520 error:0 in vxs.so[7f2065195000+6000]
    cpcpan_check_in[4535] trap invalid opcode ip:7f679ed0c1a2 sp:7fffb3bcb0e0 error:0 in SSLeay.so[7f679ecd2000+4f000]
    perl[4536] trap invalid opcode ip:7f2e21ce1ed0 sp:7fffb800cb80 error:0 in vxs.so[7f2e21cdf000+6000]
    realperlinstall[4537] trap invalid opcode ip:7f40d5351ed0 sp:7fffacf00ca0 error:0 in vxs.so[7f40d534f000+6000]
    cpcpan_check_in[4544] trap invalid opcode ip:7f051d3a11a2 sp:7fff4def9020 error:0 in SSLeay.so[7f051d367000+4f000]
    tailwatchd[4685] trap invalid opcode ip:7f4a328b83b8 sp:7fff62459bd0 error:0 in DBI.so[7f4a328a8000+19000]
    perl[4638] trap invalid opcode ip:7f0d655f5ed0 sp:7fff30ef7720 error:0 in vxs.so[7f0d655f3000+6000]
    cpanellogd[5272] trap invalid opcode ip:7f8ac671e3b8 sp:7fff6849dce0 error:0 in DBI.so[7f8ac670e000+19000]
     
  6. wizzy420

    wizzy420 Well-Known Member

    Joined:
    Nov 13, 2007
    Messages:
    125
    Likes Received:
    2
    Trophy Points:
    18
    Think I got it.

    After poking around uninstalling & reinstalling modules then a

    perl -MCPAN -e shell
    upgrade

    and a third

    /scripts/checkperlmodules --full --force

    looks like Perl is finally back
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,682
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    This can typically be resolved by installing the missing dependency. EX:

    Code:
    # yum install expect-devel
    However, anyone experiencing this issue should consider submitting a bug report via:

    Submit A Bug Report

    We prefer to track these types of issues using our internal bug reporting system so we can address this if we find it's happening across several servers.

    Thank you.
     
Loading...

Share This Page