The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Perl problems

Discussion in 'General Discussion' started by 2do, Apr 9, 2007.

  1. 2do

    2do Registered

    Joined:
    Mar 25, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I am receiving this error when ever i try to update cpanel.

    Any advice on how to change this back to yes???


    Mirror Check passed for cpan.belfry.net (/index.html)
    commit: wrote '/usr/lib/perl5/5.8.7/CPAN/Config.pm'
    CPAN: File::HomeDir loaded ok (v0.64)
    Sorry, we have to rerun the configuration dialog for CPAN.pm due to
    the following indispensable but missing parameters:

    auto_commit


    Normally CPAN.pm keeps config variables in memory and changes need to
    be saved in a separate 'o conf commit' command to make them permanent
    between sessions. If you set the 'auto_commit' option to true, changes
    to a config variable are always automatically committed to disk.

    Always commit changes to config variables to disk? [no]
     
  2. david510

    david510 Well-Known Member

    Joined:
    Aug 22, 2004
    Messages:
    473
    Likes Received:
    0
    Trophy Points:
    16
    Login to WHM go to
    Software --> Install a perl module.

    Paste File::HomeDir in the search section and when listed, click on File::HomeDir to install it. Try upcp after that.
     
  3. WebHostDog

    WebHostDog Well-Known Member

    Joined:
    Sep 3, 2006
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Website Owner
    spawn /scripts/perlinstaller File::HomeDir
    Method: Perl Expect
    Fetching CPAN timestamp...Done

    Testing connection speed...(this could take a while)...Done

    Ping:1.612 Testing connection speed to cpan-du.viaverio.com using pureperl...(6986.67 bytes/s)...Done

    Ping:6.505 Testing connection speed to mirrors.24-7-solutions.net using pureperl...(34811.11 bytes/s)...Done

    Ping:7.351 Testing connection speed to perl.secsup.org using pureperl...(79075.00 bytes/s)...Done

    Three usable mirrors located

    Mirror Check passed for perl.secsup.org (/index.html)

    commit: wrote '/usr/lib/perl5/5.8.7/CPAN/Config.pm'

    CPAN: File::HomeDir loaded ok (v0.64)

    Sorry, we have to rerun the configuration dialog for CPAN.pm due to

    the following indispensable but missing parameters:



    auto_commit





    Normally CPAN.pm keeps config variables in memory and changes need to

    be saved in a separate 'o conf commit' command to make them permanent

    between sessions. If you set the 'auto_commit' option to true, changes

    to a config variable are always automatically committed to disk.



    Always commit changes to config variables to disk? [no]






    Please remember to call 'o conf commit' to make the config permanent!



    CPAN: Storable loaded ok (v2.16)

    Going to read /home/.cpan/Metadata

    Database was generated on Mon, 09 Apr 2007 10:09:47 GMT

    File::HomeDir is up to date (0.64).

    perlmod--Install done




    It is the save David, what is the problem with this ?
     
  4. krisdv

    krisdv Well-Known Member

    Joined:
    Jun 18, 2003
    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Belgium
    I have the same issue, someone found a solution yet?
     
  5. vincentg

    vincentg Well-Known Member

    Joined:
    May 12, 2004
    Messages:
    140
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    new york
    It seems that the config file is missing.

    This needs to be in the /home/.cpan/Cpan
    The file should be MyConfig.pm

    How to create this I'm not sure.
     
  6. taotoon

    taotoon Well-Known Member

    Joined:
    Nov 14, 2004
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    I faced this problem daily too 3- 4 days.
     
  7. cpanelinfoseeker

    cpanelinfoseeker Well-Known Member

    Joined:
    Oct 25, 2002
    Messages:
    323
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    NE Illinois
    cPanel Access Level:
    Root Administrator
    Not saying if this is right or wrong, but my solution was to change the "auto_commit" to yes and UPCP seems to have run without the error appearing.

    -->Output from UPCP after 'fix'<---
    Testing connection speed...(this could take a while)...Done
    Ping:1000 Testing connection speed to cpan.wanadoo.nl using
    pureperl...(17388.89 bytes/s)...Done
    Ping:1000 Testing connection speed to ftp.rhnet.is using
    pureperl...(9037.14 bytes/s)...Done
    Three usable mirrors located
    Mirror Check passed for cpan.wanadoo.nl (/index.html)
    commit: wrote '/usr/lib/perl5/5.8.8/CPAN/Config.pm'
    CPAN: File::HomeDir loaded ok (v0.64)
    CPAN: Storable loaded ok (v2.16)
    Going to read /home/.cpan/Metadata
    Database was generated on Fri, 13 Apr 2007 13:09:54 GMT
    version is up to date (0.71).
    --->END UPCP output<---

    It wrote the Config.pm file and did not give the error. Doing a quick check of the server, it seems that everything is working fine still.

    --->My solution<---
    In SSH, make copy of
    /usr/lib/perl5/5.8.8/CPAN/Config.pm

    I then entered this command

    perl -MCPAN -e shell

    when the following line is displayed, I entered 'yes' and let it finish:

    Always commit changes to config variables to disk? [no] yes

    I then hit 'q' to exit the editor and immediately ran UPCP.

    No error on the update (see above), so it seems to be fixed.
    Checked service status and apache status in WHM and they look fine.
    --->End of My solution<---

    DISCLAIMER: Use this at your own risk as I am not an expert on Linux. This was from my own research using google, and I can not take any responsibility if this does not work on your system. Thanks for understanding - Ron
     
  8. vincentg

    vincentg Well-Known Member

    Joined:
    May 12, 2004
    Messages:
    140
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    new york
    That add this line 'auto_commit' => q[1], to the Config.pm file.

    OK - this looks 100% right to me.

    The MyConfig.pm file is for users only should they need different settings.

    Guess if I read the header of the systemwide config file I would have seen this and not been confused. lol

    Vin
     
    krisdv likes this.
  9. krisdv

    krisdv Well-Known Member

    Joined:
    Jun 18, 2003
    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Belgium
    Manually adding 'auto_commit' => q[1], to the Config.pm file solved my problems.

    Thanks Vincent!
     
  10. taotoon

    taotoon Well-Known Member

    Joined:
    Nov 14, 2004
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    Thank you for the solution ...




    somebody please wake up cpanel team......to fix it.
     
    #10 taotoon, Apr 16, 2007
    Last edited: Apr 16, 2007
  11. Angel78

    Angel78 Well-Known Member

    Joined:
    May 9, 2002
    Messages:
    413
    Likes Received:
    1
    Trophy Points:
    16
    also having this issue. It just came with one of the UPCP's few days ago.
     
  12. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    Me too! Thanks Vin
     
  13. stef

    stef Member

    Joined:
    Jun 4, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Belgium
    cPanel Access Level:
    DataCenter Provider
    Maybe a bit late, but didn't have the time to look at this earlier.
    Anyway, this solved the problem for me too.

    Thanks Vincent.
     
  14. Skin

    Skin Well-Known Member

    Joined:
    Feb 3, 2006
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Italy
    Thanks, it works also for me.
     
  15. dexus

    dexus Well-Known Member

    Joined:
    Jan 14, 2006
    Messages:
    169
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    I am just wondering, why is that row "'auto_commit' => q[1]" missing by default on all cPanel servers? Even if that should be disabled by default, that row should exist but should look like this "'auto_commit' => q[0]".

    So can someone please explain why is that row always missing?
     
Loading...

Share This Page