The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Perl process has been taking up 99% of CPU for 72 hours

Discussion in 'General Discussion' started by Jeff75, Nov 4, 2004.

  1. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    There's a Perl process that's taking up 99% of the CPU and has been running for 72 hours. I tried doing kill -HUP # but it didn't stop it. Can someone tell me how to make it end? Here's what it's doing:

    username domain.com 98.05 0.80 0.0
    Top Process %CPU 99.0 /usr/bin/spamd -d --allowed-ips127.0.0.1 --pidfile/var/run/spamd.pid --max-children5 (perl)
    Top Process %CPU 98.9 /usr/bin/spamd -d --allowed-ips127.0.0.1 --pidfile/var/run/spamd.pid --max-children5 (perl)
    Top Process %CPU 98.8 /usr/bin/spamd -d --allowed-ips127.0.0.1 --pidfile/var/run/spamd.pid --max-children5 (perl)

    Does anybody know exactly what this is and how to keep it from doing it again in the future?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That's the SpamAssassin daemon. Sounds like it's stuck in a loop. A kill HUP doesn't stop a process, it only restarts it, and then only if it looks for a HUP. I'd recommend trying:

    /scripts/restartsrv_exim

    Which should stop and restart spamd with it. If that process is still present, then you should use:

    kill -9 PID

    Then run the exim restart command above to restart spamd.
     
  3. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    Thanks for the info...that did the trick. This came up when running /scripts/restartsrv_exim. Do you have any idea how to fix it?

    antirelaydperl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LC_ALL = (unset),
    LANG = "en_US"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Did you try logging out and logging back in again, then try again? It could be that your environment settings got lost. One thing that can cause that is if you su to the root account but forget the dash:

    su -
     
  5. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    A dash? I've just been doing su root the entire time? Have I been doing it wrong? I'm on FreeBSD in case that makes a difference.
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Yes, the dash tells su that you want to inherit shell (and the environment) of the target account. It's actually an alternative of the -l switch, so you an think of it as:

    su -l root
     
Loading...

Share This Page