Marty

Well-Known Member
Oct 10, 2001
630
1
318
I am having a problem with /scripts/upcp and the perl installer for 5.8.8 freezing at the following:

Code:
SQL-Statement-1.15/Makefile.PL
SQL-Statement-1.15/README
CPAN: File::Temp loaded ok (v0.16)

  CPAN.pm: Going to build J/JZ/JZUCKER/SQL-Statement-1.15.tar.gz


WARNING! You seem to have an older version of SQL::Statement already installed.                                                                                                   This new version introduces a number of features that will impact operation of                                                                                                  SQL::Statement and of DBD drivers for CSV, AnyData, and Excel.  Changes include:

  1. There are *many* new SQL features including table joins
  2. BLOBS, Empty strings, and NULLs behave differently
  3. Some applications may run a bit slower than previously

See the README for details.

Press enter to continue ...
I can press enter, but nothing happens.

Any suggestions??
 

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,488
35
158
cPanel Access Level
DataCenter Provider
Looks like it changed from

Press return to continue

to

Press enter to continue

in the SQL-Statement-1.15 perl module installer.

The expect script should timeout after 300 seconds.

We'll add 'Press enter to continue' to the list of things the perl installer knows how to handle in todays build.
 

BenThomas

Well-Known Member
Feb 12, 2004
598
0
166
Houston, Texas USA
cPanel Access Level
Root Administrator
Funny, I tried to recreate this issue on several servers and the CPAN module installation never provided such a prompt. In light of your report, we've added a check for this prompt so the installer shouldn't hang there. This will be in today's builds.