cweb

Member
Dec 9, 2002
19
0
151
Hi ,

I have had this on a couple of servers overnight. Sometime ago we ran the perl upgrade to version 5.8.5 this went well and all was good. However last night the servers have reverted back to 5.8.0 This has caused MailScanner to no longer process mail.

I am now upgrading perl to 5.8.8 and once complete mailscanner begins to function again. What I have not yet found out is why perl reverted back to version 5.8.0?
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
31
473
Go on, have a guess
You probably don't have perl* disabled in your OS update configuration (up2date or yum) and the OS is "downgrading" it to the OS vendor supplied version.
 

EWD

Well-Known Member
PartnerNOC
Aug 19, 2003
165
0
166
NY
This just happened to me as well on a bunch of servers.
upcp is overwriting yum.conf and it is removing perl* from the conf file.
 

EWD

Well-Known Member
PartnerNOC
Aug 19, 2003
165
0
166
NY
It seems this is a result of having "Allow Perl updates from RPM based linux vendors" checked.
 

caeos

Well-Known Member
Jul 18, 2007
79
0
56
UK
so do we do what it suggests in the email i got sent by my nice server? along with the comments about not being able to find OSCAR...?:confused:

The version of perl you are running (v5.8.5) is too old. There are known problems that cannot be worked around with this version of perl. It is HIGHLY recommended that you upgrade to v5.8.8 or later. Any module install failures should be ignored until perl has been upgraded as some modules will not be able to install with this version of perl.

You can ensure that each installed module gets carried over to
the updated Perl build with the use of the "autobundle" CPAN feature.

You can create a bundle of the currently installed modules
by executing the following while logged in via SSH as root:

perl -MCPAN -e 'autobundle'

Once completed, you should see the following output before getting
returned to the shell:

'Wrote bundle file /home/.cpan/Bundle/Snapshot_2007_08_16_00.pm'

Once you've made note of this file name, you can proceed with the update.

On linux based systems, you should be able to update Perl using
the installer provided at layer1.cpanel.net:

cd /root
wget http://layer1.cpanel.net/perl588installer.tar.gz
tar -zxf perl588installer.tar.gz
cd perl588installer
./install

On FreeBSD based systems, you will need to install Perl from ports.

This will take a few minutes, so take a coffee break and check
the status when you return. Once the update has completed, you
can install all previously installed modules from the CPAN bundle
by executing the following (with the bundle name adjusted to the
name of the bundle generated earlier):

perl -MCPAN -e 'install Bundle::Snapshot_2007_08_16_00'

This should install each of the modules present in the bundle,
assuming there are no issues during the installation (dependencies,
network, etc).

Once this has completed, execute the following to ensure that all modules
required by cPanel are installed, and restart cPanel:

/usr/local/cpanel/bin/checkperlmodules
/usr/local/cpanel/startup
 

chaloupe

Well-Known Member
Mar 17, 2006
54
0
156
Dieppe, NB, Canada
I had the same issue this morning with Perl being downgraded to 5.8.5 on many of our servers.

How/Where do we make sure it doesn't happen again? In Update Config?

Using CENTOS Enterprise 4.5 i686

Best Regards,
 

AndyReed

Well-Known Member
PartnerNOC
May 29, 2004
2,217
4
193
Minneapolis, MN
I had the same issue this morning with Perl being downgraded to 5.8.5 on many of our servers.

How/Where do we make sure it doesn't happen again? In Update Config?

Using CENTOS Enterprise 4.5 i686
Although disabling this option might not be necessary, login to the WHM >> Configuration >> Tweak Settings and de-activate this option:
Allow Perl updates from RPM based linux vendors

You also need to add perl* to the exclude services in up2date and yum.conf
 
Last edited:

chaloupe

Well-Known Member
Mar 17, 2006
54
0
156
Dieppe, NB, Canada
Although disabling this option might not be necessary, login to the WHM >> Configuration >> Tweak Settings and de-activate this option:
Allow Perl updates from RPM based linux vendors

You also need to add perl* to the exclude services in up2date and yum.conf
Thanks for the info on the yum.conf :)
 

EWD

Well-Known Member
PartnerNOC
Aug 19, 2003
165
0
166
NY
If you uncheck "Allow Perl updates from RPM based linux vendors", next time upcp runs, it will add perl* to the exclude list


I believe this is one those things that has been broken in cpanel forever and all of a sudden it gets fixed and catches everyone by surprise.

I am too pretty sure perl* was on my exclude list in yum.conf.
 

tkerns

Active Member
Jun 13, 2007
34
0
56
I had this same thing happen to me. After updating perl to 5.8.8, and doing a upcp --force, cpanel will not start.

I try service cpanel restart, and it all appears to start just fine, but I cannot get into whm.

Did anybody else have this problem ? I am running cpanel 11 release on a Cent OS box.

Thanks.

Tom
 

caeos

Well-Known Member
Jul 18, 2007
79
0
56
UK
i followed the instructions in the email the server sent me and it worked a treat, albeit took a while.

will try the perl exlude thing later/
 

tkerns

Active Member
Jun 13, 2007
34
0
56
I followed those instructions, and it did not work... but after messing with it a while, we ran it again, and that time it 'took'
Cpanel is up and happy again.

I looked in tweak settings, and that checkbox is unchecked.
II checked in /etc/yum.conf, and perl* is in the exclude list.
Where is up2date? is that something else that needs to have perl* in the exclude list?
 

rudedog

Member
Aug 14, 2006
5
0
151
How long should reinstalling the bundle you created take? mine has been running for about an hour now.

Thanks in advance.