Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Permanently disable ForcePassiveIP option

Discussion in 'General Discussion' started by Carlos Campano, Apr 7, 2017.

Tags:
  1. Carlos Campano

    Carlos Campano Registered

    Joined:
    Apr 5, 2017
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Santiago que es Chile
    cPanel Access Level:
    DataCenter Provider
    Hello, I need disable ForcePassiveIP from my /etc/pure-ftpd.conf, when the file is saved works great, but with every update of cpanel, is actived by default.

    how I can prevent this?

    tks for your help
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,659
    Likes Received:
    1,428
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
  3. QuentinC

    QuentinC Member

    Joined:
    Jan 10, 2013
    Messages:
    8
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    DataCenter Provider
    Hi cPanelMichael,

    Thanks you for your replied, it's really appreciated !

    With cPanel server under NAT, we have a lots of issues with the FTP: each cPanel update version/build the FTP configuration file
    /etc/pure-ftpd.conf is regenerated.

    On CentOS7 the PassivePortRange is set from 49152 to 65534 but on CentOS6 those value was 30 000 50 000 (easy to give to the customer by phone and easy to learn)

    Now with a naked CentOS7 you have this:

    Code:
    cat /etc/pure-ftpd.conf | grep Pass
    PassivePortRange 49152 65534
    ForcePassiveIP 185.22.110.X
    I try your process, it's work for the PassivePortRange but not the ForcePassiveIP !

    Code:
    
    rm /var/cpanel/conf/pureftpd/main.cache -f
    ---
    vi /var/cpanel/conf/pureftpd/main
    
    #Edit this line
    PassivePortRange: 49152 65534
    #to
    PassivePortRange: 30000 50000
    
    #Remove this line
    ForcePassiveIP: 146.88.233.X
    ---
    /scripts/setupftpserver pure-ftpd -—force
    ---
    cat /etc/pure-ftpd.conf | grep Pass
    PassivePortRange 30000 50000
    ForcePassiveIP 185.22.110.X
    
    Do you have an other solution for us ?

    Best regards.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,659
    Likes Received:
    1,428
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello @QuentinC,

    This is actually a bug in cPanel version 64. Internal case CPANEL-13189 will address an issue where changes to the ForcePassiveIP value in the /var/cpanel/conf/pureftpd/main file are not retained. The resolution is included in cPanel version 66:

    Fixed case CPANEL-13189: Allow overriding pure-ftpd configuration settings.

    In the meantime, the workaround is to manually edit the /etc/pure-ftpd.conf with your preferred changes.

    Thank you.
     
  5. QuentinC

    QuentinC Member

    Joined:
    Jan 10, 2013
    Messages:
    8
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    DataCenter Provider
    Did you plan to backport this bug to 64 ?
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,659
    Likes Received:
    1,428
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    There are no plans to publish that resolution to cPanel version 64. However, cPanel version 66 is tentatively scheduled for publication to the "Release" build tier within the next week.

    Thank you.
     
Loading...

Share This Page