Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

permenently disabling disk quotas

Discussion in 'General Discussion' started by chilihost, Dec 20, 2005.

  1. chilihost

    chilihost Well-Known Member

    Joined:
    Mar 1, 2005
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    156
    disk quotas are a constant hassle for me and I don't need them, what is the best way to permanently disable them on an entire server? Does:
    quotaoff -av
    work and will this keep the quotas disabled even after a reboot?

    thanks!
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,472
    Likes Received:
    20
    Trophy Points:
    463
    Location:
    Go on, have a guess
    No. You should remove the usrquota parameter from your disks in /etc/fstab to achieve that.
     
  3. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    193
    Location:
    Minneapolis, MN
    To achieve this goal, you'll need to re-compile your Kernel with quota off.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,472
    Likes Received:
    20
    Trophy Points:
    463
    Location:
    Go on, have a guess
    AFAIK, No, you don't. You only need to make the fstab modification I mentioned and then turn off quotas and remove the quota files as I mentioned.
     
  5. chilihost

    chilihost Well-Known Member

    Joined:
    Mar 1, 2005
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    156
    thank you I will try removing that parameter.
     
  6. chilihost

    chilihost Well-Known Member

    Joined:
    Mar 1, 2005
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    156
    My /etc/fstab file looks like this:
    Code:
    LABEL=/                 /                       ext3    defaults,usrquota        1 1
    LABEL=/boot             /boot                   ext2    defaults        1 2
    none                    /dev/pts                devpts  gid=5,mode=620  0 0
    LABEL=/home2            /home2                  ext3    defaults        1 2
    none                    /proc                   proc    defaults        0 0
    none                    /dev/shm                tmpfs   defaults        0 0
    /dev/hda2               swap                    swap    defaults        0 0
    /dev/fd0                /mnt/floppy             auto    noauto,owner,kudzu 0 0
    
    so should I just remove that ,usrquota bit?

    thanks again.
     
  7. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    India
    Hello,

    Run the command
    quotaoff -a
    Then remove the entry userquota from fstab, It will help you ;)
     
  8. chilihost

    chilihost Well-Known Member

    Joined:
    Mar 1, 2005
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    156
    perfect, thanks!
     
Loading...

Share This Page