Permission denied: creating lock file hitching post

Status
Not open for further replies.

awnlionel

Member
Jul 11, 2005
9
0
151
Hi there,
I am getting this kind of message when i tried to force the delivery of emails wich are sitting in the queue I saw some post about it but no solutions is anybody can tell me how to resolve this please?
Couldn't open spool file for 1Ds6Zv-0002ZJ-Uh: Permission denied
delivering 1Ds6Zv-0002ZJ-Uh
LOG: MAIN
== [email protected] R=virtual_user T=virtual_userdelivery defer (13): Permission denied: creating lock file hitching post /home/animatio/mail/animationweek.com/dan/inbox.lock.host101.aff.com.42d319e6.0000377c (euid=32003 egid=12)
LOG: MAIN
failed to open database lock file /var/spool/exim/db/retry.lockfile: Permission denied (euid=47 egid=12)
LOG: MAIN PANIC DIE
failed to unlink /var/spool/exim/input/v/1Ds6Zv-0002ZJ-Uh-J: Permission denied
Thanks for your help!
 

awnlionel

Member
Jul 11, 2005
9
0
151
additionnaly it s what i get from another email address

Couldn't open spool file for 1Ds6Zv-0002ZJ-Uh: Permission denied
delivering 1Ds6Zv-0002ZJ-Uh
LOG: MAIN PANIC DIE
failed to unlink /var/spool/exim/msglog/v/1Ds6Zv-0002ZJ-Uh
Return to Mail Queue
suggestions? help?
 

awnlionel

Member
Jul 11, 2005
9
0
151
Ok has not received any help in an entire day here is what you can do to resolve the problem i created the post for
do /script/mailperm it will fix all of it but not i have User 0 set for local_delivery transport is on the never_users list
anybody know how to fix this one?
 

awnlionel

Member
Jul 11, 2005
9
0
151
resolved the last problem too just forward the email from whm to the default account for example and here you go, last problem will be that no email are being delivered, can send to anybody but cannot see the reply i made no bounceback message as well if anybody got an idea ?
 

nickb

Well-Known Member
Feb 25, 2005
346
0
166
India
Using the default configuration, Exim runs as the local user when doing a local delivery, and it uses a lock file to prevent any other process from updating the mailbox while it is writing to it. Check the ownership on this user's mail box [email protected]. The correct settings are user.mail.
 

its_joe

Well-Known Member
Feb 15, 2007
134
0
166
Remove the lock files (inbox.lock*) from the mail directory (/home/animatio/mail/animationweek.com/dan/) . After that restart the mail services and the issue will get resolved.
 
Status
Not open for further replies.