The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Permission issues after disabling mod_ruid2

Discussion in 'General Discussion' started by bhanuprasad1981, May 23, 2013.

  1. bhanuprasad1981

    bhanuprasad1981 Well-Known Member

    Joined:
    Aug 5, 2008
    Messages:
    222
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    seems permission issues arising after disabling ruid2 is this issue resolved ?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you provide more information about the specific permission issues that arise? For example, what specific error messages appear in the Apache error log?

    Thank you.
     
  3. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    When using mod_ruid2, web content and web applications will be served as the cPanel user that owns the domain. Any files, or directories, that are created by web applications will have a specific set of ownership and permissions. If you then change from mod_ruid2, and begin serving web applications in a different method (e.g. mod_php, or PHP DSO), you will encounter ownership and permission errors.

    At this point you have a few options:

    1. Return to using mod_ruid2 (really we'd love to know the reason you switched away)
    2. Configure Apache to use suPHP, suExec and related handlers, which serve web applications as the user that owns the domain
    3. Perform the risky operation of changing all the permissions to modes that are acceptable to your current configuration.
     
Loading...

Share This Page