Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Permission problems in wordpress

Discussion in 'General Discussion' started by Christos Liaskonis, Oct 28, 2018.

Tags:
  1. Christos Liaskonis

    Christos Liaskonis Registered

    Joined:
    Oct 28, 2018
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    greece
    cPanel Access Level:
    Website Owner
    Hello, I am trying to open a ticket but i cant find my support id i dont have whm. My problem is that I am trying to install a plugin in wordpress from the wordpress dashboard i am unable to do that but i have successfully done it with FTP. The only problem is that i cannot activate it. The plugin is "all in one wp migration". This also happens with other plugins. When i am trying to import from the plugin i get errors about file creations and permission errors, the one that persists is the error in the image attached. It says to check the permissions in the storage folder of the plug-in but i have triple checked and everything is set to 777, but its still not working. It would be realy helpfull if you suggest me something or i can even give an author access so that he can take a look. Thanks for your time.
     

    Attached Files:

  2. rpvw

    rpvw Well-Known Member

    Joined:
    Jul 18, 2013
    Messages:
    1,088
    Likes Received:
    441
    Trophy Points:
    113
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    Some scripts will advise you to set all the permissions to 777, but that does not always work with cPanel

    The normal cPanel permissions given to files and folders in the ~/public_html folder are:

    Folders 755
    Files 644

    You should try those settings first; and see if your "all in one wp migration" plugin works as expected.

    If it still doesn't work, you may need to ask your web host for assistance.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    cPanelMichael likes this.
  3. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,002
    Likes Received:
    2,123
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @Christos Liaskonis,

    The information in the previous post is correct. If that doesn't help, since you are a website owner without root access to the server, I recommend reporting this problem to your web hosting provider for additional assistance. They should be able to review the Apache error logs to determine which specific directory or file doesn't have the correct permissions.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice