Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED Permissions and Ownerships issues

Discussion in 'General Discussion' started by WorkinOnIt, Dec 2, 2016.

Tags:
  1. WorkinOnIt

    WorkinOnIt Well-Known Member

    Joined:
    Aug 3, 2016
    Messages:
    138
    Likes Received:
    9
    Trophy Points:
    18
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    I've recently set up a new vps with cpanel / cloudlinux using suPHP and EA4 (centOS).

    When I create an new account, it seems to always create the /public_html folder as user:user (rather than user:nobody)

    Directories are correctly given 755 but files are being created with permission 644 - though I'm wondering if they should they be 664?

    What could the issue be - or is this the correct setting?

    I'm not seeing any specific errors on the frontend website (wordpress) but I don't seem able to display any errors - not even php notices are showing.... though debug constants and error reporting are all set to true/on.
     
    #1 WorkinOnIt, Dec 2, 2016
    Last edited: Dec 2, 2016
  2. SysSachin

    SysSachin Well-Known Member

    Joined:
    Aug 23, 2015
    Messages:
    604
    Likes Received:
    43
    Trophy Points:
    28
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    644 is correct file permission and it should be always 644.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,803
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    cPanel will automatically assign the correct group ownership values to the public_html directories (e.g. it checks Mod_Ruid2/MPM-ITK and FileProtect settings). 0644 permissions for files and 0755 permissions for directories are correct, and the recommended permission values for files and directories.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. WorkinOnIt

    WorkinOnIt Well-Known Member

    Joined:
    Aug 3, 2016
    Messages:
    138
    Likes Received:
    9
    Trophy Points:
    18
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    Ok thank you - but why are new accounts being created with ownership of public_html as user:user? I am creating them manually as root login.

    Should they not be user:nobody?

    In addition, the /public_html is being given 755 also and I thought it should be 750.

    What could be causing that?
     
  5. WorkinOnIt

    WorkinOnIt Well-Known Member

    Joined:
    Aug 3, 2016
    Messages:
    138
    Likes Received:
    9
    Trophy Points:
    18
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    Just to update this thread - I opened a support ticket and the reply was very helpful;

     
    #5 WorkinOnIt, Dec 4, 2016
    Last edited by a moderator: May 2, 2017
  6. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,803
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    I'm happy to see the information helped! Thank you for updating this thread with the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice