Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Permissions changed to nobody on public_html

Discussion in 'General Discussion' started by fozziebear, Aug 10, 2017.

  1. fozziebear

    fozziebear Registered

    Joined:
    Aug 10, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Queensland, Australia
    cPanel Access Level:
    Website Owner
    Periodically my sites display 403 forbidden errors... When I go and investigate the public_html folder the group is changed to nobody (owner is correct and remains unchanged). As I have nginx as a front end with reverse proxy to cpanel/apache then I have a group 'mygroup' which has both nobody and the nginx user. So correct settings for this folder should be mygroup:myowner

    This configuration works well as I don't want general read rights outside of nginx/apache (for the group). The owner is of course php-fpm for that particular site and permissions are scripted for security reasons.

    I can't figure out "what" in my system is changing permissions on this folder (public_html)? Is there a script or variable that cpanel uses for group ownership?

    a grep -rnw '/usr/local/cpanel/scripts' -e 'nobody' reveals several scripts with reference to nobody. pkgacct has my $httpuser = 'nobody' on line 175.

    Is there a way to tell cpanel to leave group permissions alone?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,165
    Likes Received:
    1,372
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page