cornelombaard

Member
Apr 24, 2013
5
0
1
cPanel Access Level
Root Administrator
I have a VPS with WHM and Cpanel

When I create a new account I always have a permission problem in that certain things are just not being allowed to the account and so installing any cms is a huge problem. I constantly have permission denied errors and one instance after changing every single file and folder including even the public_html folder to 777 I still got a operation not allowed.

So now I am asking please who should be the owner of the public_html folder? The account nobody or the actual account holder? Because it seems that this is the issue.

Any help will really be greatly appreciated.
 

MatthewM.

Member
Jul 22, 2013
5
1
3
cPanel Access Level
Root Administrator
Hey there!

The public html should have the ownership of user:nobody and should be set to 750. You can set that with:

chown user:nobody /home/$user/public_html
chmod 750 /home/$user/public_html

If you can't get it going with that then I'd suggest opening up a ticket with us so we can take a look for you :)

http://go.cpanel.net/supportrequest

You can post the ticket number here so we can update this thread with the outcome.

Thanks!
 

cornelombaard

Member
Apr 24, 2013
5
0
1
cPanel Access Level
Root Administrator
Thank you for the quick response. The permissions are set exactly like you say here and the folder belongs to nobody. I have changed all the folder (inside public_html) permissions to 777 and still I get the permission problem. It is like the user nobody does not have enough permissions inside the directory public_html to enable the creation of folders or the change of folder permissions. I have a VPS with a hosting company and so I doubt if I have support from CPane on that and they hosting company keep telling me nothing is wrong but it is clearly

I managed to create a support ticket 4343333
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,241
363
Hello :)

It's likely better that you use suPHP as your PHP handler so you do not have to manually modify the permissions on directories to insecure values. You can change your PHP handler via:

"WHM Home » Service Configuration » Configure PHP and suEXEC"

You can review the considerations for suPHP at:

suPHP Considerations

Thank you.