glenn0

Well-Known Member
Jul 23, 2012
67
2
8
cPanel Access Level
Website Owner
I was recently suffering with a 'Not Supported' message when browsing my website. I started reading up where I could and came across:
https://documentation.cpanel.net/display/66Docs/Apache+FAQ#ApacheFAQ-WhydoIreceivea%22NotSupported%22messagewhenIattempttoaccessmywebsitewithamod_userdir-styleURL?
Apache FAQ - Version 66 Documentation - cPanel Documentation
https://documentation.cpanel.net/display/66Docs/Apache+FAQ#ApacheFAQ-WhydoIreceivea%22NotSupported%22messagewhenIattempttoaccessmywebsitewithamod_userdir-styleURL?
I followed this and it cured the 'Not Supported' message. It has now created another problem where session cookies are not being stored and Wordpress installs on that server require FTP access to modify/update plugins etc. This is all pointing to a permissions problem.

Can anybody tell me how best to proceed please?

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello,

I recommend first reinstalling the modules you removed and accessing the website without using the Mod_Userdir URL to rule that out as the source of the problem. The following document explains how to modify the hosts file on your computer to access a domain name directly before it resolves to your server:

How to Modify your hosts File - cPanel Knowledge Base - cPanel Documentation

Thank you.
 

glenn0

Well-Known Member
Jul 23, 2012
67
2
8
cPanel Access Level
Website Owner
Hi Michael,

I was never using the Mod_Userdir URL, but was receiving the 'Not Supported' error, which the above cured for me. With this in mind, how can I get things working again?

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
I was never using the Mod_Userdir URL, but was receiving the 'Not Supported' error, which the above cured for me.
Are you sure WordPress wasn't configured with a Mod_Userdir URL in it's configuration setting? You shouldn't receive the "Not Supported" message unless you or your script is accessing the website with that URL (e.g. hostname.com/~username).

I recommend reinstalling the modules you removed to restore the previous behavior.

Thank you.