The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

pgsql extension- Not able to enable

Discussion in 'EasyApache' started by Geeessoft, Apr 18, 2015.

  1. Geeessoft

    Geeessoft Registered

    Joined:
    Mar 22, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi

    I have installed PostgreSQL 9.4.1 manually. I tried enabling the extension pgsql using the easyapache. It shows the following error

    The last time Cpanel::Easy:PHP5:pgsql was run; step returned 0.

    That just caused Cpanel::Easy:PHP5:pgsql to be skipped.

    The message it gave was:
    Code:
    Unable to find postgresql path
    
    
    You might want to take that into consideration when choosing options and troubleshooting.
    
    The log for that build is here: /usr/local/cpanel/logs/easy/apache/build.1429380511
    
    In the log i see the following msg

    Code:
    -- Begin opt 'PGsql' --
        -- Begin dryrun test 'Check postgresql' --
        -- End dryrun test 'Check postgresql' --
    
        -- Begin dryrun test 'Check postgresql for PHP 5' --
        dryrun test 'Check postgresql for PHP 5' did not return true
    
        !! Dry run failed for 'Cpanel::Easy::PHP5::pgsql' skipping option !!
    
    -- End opt 'PGsql' --
    
    Can any one guide me? Its bit urgent.

    Thanks in advance
     
    #1 Geeessoft, Apr 18, 2015
    Last edited by a moderator: Apr 20, 2015
  2. cPJacob

    cPJacob cPanel Product Owner
    Staff Member

    Joined:
    May 2, 2014
    Messages:
    510
    Likes Received:
    66
    Trophy Points:
    28
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hello,

    cPanel does not support PGSQL 9. As far as I know, you won't be able to use EasyApache with this version either.
     
Loading...

Share This Page