The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Photo Gallery Installation

Discussion in 'Database Discussions' started by donlor18, Mar 23, 2007.

  1. donlor18

    donlor18 Registered

    Joined:
    Mar 20, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I've installed Gallery 2.0.2, (it seemed to go ok) in my "public_htmp/gallery" folder. When I display the "/gallery/index.php" file I get the gallery screen page with this on it;

    Login Register
    Gallery

    Advanced Search
    Add Album To Cart View Slideshow View Slideshow (Fullscreen) Gallery
    This is the main page of your Gallery
    Date: 12/31/1969 Owner: Don
    This album is empty.


    When I click the "login" I get;

    Not Found
    The requested URL /gallery/main.php was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


    Would appreciate any help.
    Thanks


    -------------------------------------------------------------------------------

    Apache/1.3.37 Server at localhost.localdomain Port 80
     
  2. Silver_2000

    Silver_2000 Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    338
    Likes Received:
    1
    Trophy Points:
    18
    I would use mysqladmin to look at the config
    It sounds like you may not have the folder paths defined correctly or all the files didnt install correctly - or the permissions are jacked up - if the file exists at /gallery/main.php then check it and the folders permissions, then check the settings in mysql

    or you could go here http://codex.gallery2.org/Downloads

    and dload 2.2 which is the most recent version and use the documentation to see if it helps troubleshoot -
    I use photopost so Im not that familiar with Gallery

    Doug
     
  3. david510

    david510 Well-Known Member

    Joined:
    Aug 22, 2004
    Messages:
    473
    Likes Received:
    0
    Trophy Points:
    16
    This happened, because you specified wrong path while gallery installation. Either you will need to manually edit the gallery database configuration or re-install gallery
     
  4. larryl

    larryl Active Member

    Joined:
    Feb 19, 2007
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    I've got about 50 of these running on the new cPanel server. During the configuration the path has to be the absolute path -- i.e., /home/username/www/gallery, etc. We've got the g2data file in /home/username/g2data, away from public access. Everything's running like a champ. Unlike our other servers, phpsuexec forces all of the uploaded pictures to show up in the user's quota.

    Give me a shout if you want any specific help. We've been a huge Gallery user for years.
     

Share This Page