The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

php 4.3.10 and gallery dont work

Discussion in 'General Discussion' started by salvatore333, Dec 19, 2004.

  1. salvatore333

    salvatore333 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    I upgraded php to 4.3.10 and now a customers gallery does not work. error messages when attempting to go to the gallery are:

    Warning: Illegal offset type in /home/xxxxxxxx/public_html/gallery/init.php on line 27

    Warning: Illegal offset type in /home/xxxxxxxx/public_html/gallery/init.php on line 28

    Warning: Illegal offset type in /home/xxxxxxxx/public_html/gallery/init.php on line 29

    Warning: Illegal offset type in /home/xxxxxxxx/public_html/gallery/init.php on line 30

    Warning: Illegal offset type in /home/xxxxxxxx/public_html/gallery/init.php on line 27

    Warning: Illegal offset type in /home/xxxxxxxx/public_html/gallery/init.php on line 28

    Warning: Illegal offset type in /home/xxxxxxxx/public_html/gallery/init.php on line 29

    Warning: Illegal offset type in /home/xxxxxxxx/public_html/gallery/init.php on line 30

    Warning: Illegal offset type in /home/xxxxxxxx/public_html/gallery/init.php on line 27

    Warning: Illegal offset type in /home/xxxxxxxx/public_html/gallery/init.php on line 28

    Warning: Illegal offset type in /home/xxxxxxxx/public_html/gallery/init.php on line 29

    Warning: Illegal offset type in /home/xxxxxxxx/public_html/gallery/init.php on line 30

    Fatal error: Call to a member function on a non-object in /home/xxxxxxxx/public_html/gallery/classes/User.php on line 141



    any clue of a resolution will be highly appreciated.
    a nice holiday season to all.
     
  2. cPanelKyle

    cPanelKyle Technicial Analyst III/Migrations Specialist
    Staff Member

    Joined:
    Feb 10, 2003
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Twitter:
    Try to update to the latest version of Zend Optimizer and see if that fixes the problem.

    /scripts/updatenow
    /scripts/installzendopt
     
  3. peddler

    peddler Active Member

    Joined:
    Mar 26, 2003
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    I had similar issues with PhotoPost, but upgrading Zend resolved them.
     
  4. dezignguy

    dezignguy Well-Known Member

    Joined:
    Sep 26, 2004
    Messages:
    534
    Likes Received:
    0
    Trophy Points:
    16
    My gallery 1.4.4pl4 works fine with php 4.3.10 so it must be something else... try upgrading Zend like the others suggest.
     
  5. AlexF

    AlexF Well-Known Member

    Joined:
    Nov 20, 2003
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    As a side note, both Zend and IonCube loaders need to be upgraded for PHP 4.3.10 to work properly on several scripts.. :)

    Merry Christmas!
     
  6. ret

    ret Active Member

    Joined:
    Nov 5, 2004
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    PHP 4.3.10
    Zend Engine v1.3.0
    ionCube PHP Loader v2.5
    Zend Extension Manager v1.0.6
    Zend Optimizer v2.5.7

    Upgraded php, zend, then installed ion for freebsd. Gallery still does'nt work.
     
  7. fusioncroc

    fusioncroc Well-Known Member

    Joined:
    Sep 28, 2004
    Messages:
    261
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    U.K.
    it should be zend 2.5.7
     
  8. ret

    ret Active Member

    Joined:
    Nov 5, 2004
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Thanks for the reply, The Optimizer is v2.5.7
     
  9. AP

    AP Well-Known Member

    Joined:
    Nov 5, 2002
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    how can i update IonCube loaders?

    Thanks
     
  10. HostBrasil.net

    Joined:
    May 19, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    São Paulo
    very good. I Thanks resolved my problem ;-)
     
Loading...

Share This Page