The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

php 4.3

Discussion in 'General Discussion' started by Radio_Head, Jan 12, 2003.

  1. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    Anyone may tell me if the latest apache build contains php 4.3 ?
    Thanks
     
  2. jimcarter

    jimcarter Well-Known Member

    Joined:
    Jun 30, 2002
    Messages:
    152
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    UK
    No, it doesnt,
    they are still testing the php4.3 one due to a few bugs
     
  3. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    Thanks
     
  4. twhiting9275

    twhiting9275 Well-Known Member

    Joined:
    Sep 26, 2002
    Messages:
    538
    Likes Received:
    15
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Twitter:
    Actually, I managed to get 4.3 compiled in seperately, rather easily enough. So far, I've heard no complaints about bugs and the like.
     
  5. BlueBeBe

    BlueBeBe Member

    Joined:
    Aug 14, 2001
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    [quote:28eca92d13][i:28eca92d13]Originally posted by twhiting9275[/i:28eca92d13]
    Actually, I managed to get 4.3 compiled in seperately, rather easily enough. So far, I've heard no complaints about bugs and the like.
    [/quote:28eca92d13]

    Same here :)
     
  6. null

    null Member

    Joined:
    Dec 14, 2002
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Guys, how did you install php 4.3.0?

    I always get the message to reinstall php with -DEAPI.

    How can I fix that?

    Thank you
     
  7. twhiting9275

    twhiting9275 Well-Known Member

    Joined:
    Sep 26, 2002
    Messages:
    538
    Likes Received:
    15
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Twitter:
    [quote:faff3fc3af][i:faff3fc3af]Originally posted by null[/i:faff3fc3af]

    Guys, how did you install php 4.3.0?

    I always get the message to reinstall php with -DEAPI.

    How can I fix that?

    Thank you[/quote:faff3fc3af]
    Magic ;)
    Actually, you have to pretty much take a few shortcuts. Here's how I did it though, cut and dried.
    A& /scripts/easyapache -- Let this complete, choose option 4 , it'll stop when it's done.
    B& wget -O /tmp/php.tar.bz2 http://www.php.net/do_download.php?mr=http%3A%2F%2Fwww.php.net%2F&df=php-4.3.0.tar.bz2
    C& mv /tmp/php.tar.bz2 /home/cpapachebuild/buildapache
    D& cd /home/cpapachebuild/buildapache
    E& bunzip2 php.tar.bz2
    F& tar xvf php.tar.bz2
    G& cd php-4.3.0
    H& './configure' '--with-apxs=/usr/local/apache/bin/apxs' '--with-xml' '--enable-bcmath' '--enable-calendar' '--enable-ftp' '--with-gd' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--with-mcrypt' '--enable-magic-quotes' '--with-mysql' '--with-pear' '--enable-sockets' '--enable-track-vars' '--with-ttf' '--with-freetype-dir=/usr' '--enable-gd-native-ttf' '--enable-versioning' '--with-zlib' '--with-curl' '--enable-xml' '--enable-trans-id' '--enable-mm=shared' '--enable-wddx=shared' '--with-mbstring' '--with-mbstr-enc-trans' '--enable-track-vars' '--with-gdbm' '--enable-exif'
    I&make
    J& make install
    K& restart apache

    Now that's ONE hell of a lot of configuration, and depending upon your server you may or may not want to disable some of those options. However, that's the base I use, and I've had NO complaints at all (aside from obsolete functions).
     
Loading...

Share This Page