bigj

Well-Known Member
Aug 9, 2003
75
0
156
Tucson,AZ
*sigh* Here we go.

When I configure PHP with this:

'./configure' '--enable-pic' '--with-libdir=lib64' '--prefix=/usr' '--with-xml' '--enable-bcmath' '--enable-calendar' '--with-curl' '--enable-ftp' '--with-gd' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--enable-mbstring' '--enable-mbstr-enc-trans' '--enable-mbregex' '--with-mcrypt' '--enable-magic-quotes' '--with-mysqli' '--with-mysql=/usr' '--with-openssl' '--enable-discard-path' '--with-pear' '--enable-sockets' '--enable-track-vars' '--with-zlib' '--with-xmlrpc' '--with-dom'

it chokes on:

'--with-xpm-dir=/usr/X11R6'

with this error:

configure: error: Problem with libXpm.(a|so) or libX11.(a|so). Please check config.log for more information.

I know this error has been talked about untold times in the past and researching each solution didn't solve my problem. I have both a /usr/X11R6/lib and a /usr/X11R6/lib64 directory and I'm not sure if this is causig the problem.

The box is Centos 4.x x86_64 (I could be wrong on the version but I know it's x86_64). I have all the required libraries like xorg-x11-devel installed. In fact this version of PHP was compiled back in November using this exact same string minus the last two flags and I had no problems.

Anyone have any suggestions?

--
bigj