Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

PHP 4.4.2 Released

Discussion in 'General Discussion' started by avio, Jan 15, 2006.

  1. Jones

    Jones Well-Known Member

    Joined:
    Jul 10, 2004
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    156
    For Pear: You need to upgrade this.

    For Scott: A lot of things can break php in 64bit environment.

    Try to run /scripts/easyapache then choose 4 or 5.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. simplestar

    simplestar Well-Known Member

    Joined:
    Nov 15, 2005
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    156
    I got the Pear errors on Edge version too. I'll try re-compiling again.
     
  3. networxhosting

    networxhosting Well-Known Member PartnerNOC

    Joined:
    Apr 22, 2003
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Hamilton, Ontario, CANADA
    Forgive my ignorance but do you have any suggestions on the best way to upgrade PEAR before doing an easyapache to prevent the errors listed in the above post? Centos 3.6 and latest cPanel CURRENT build

    Any help would be appreciated!
     
  4. DigitalN

    DigitalN Well-Known Member

    Joined:
    Sep 23, 2004
    Messages:
    420
    Likes Received:
    1
    Trophy Points:
    168
    You can manage the pear packages from command line..

    (List Installed Packages)

    # pear list

    (List Available Upgrades)

    # pear list-upgrades

    (Upgrade Package)

    # pear upgrade

    Try

    # pear help

    or

    # pear help <option>

    For added information.
     
  5. BenThomas

    BenThomas Well-Known Member

    Joined:
    Feb 12, 2004
    Messages:
    598
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Houston, Texas USA
    cPanel Access Level:
    Root Administrator
    Please correct me if I'm wrong, but this message can be safely ignored.

    It looks like PHP 4.4.2 is including Archive_Tar 1.13, and apparently the "pear people" think you should be using a later version (1.3.1, AFAIK). So the pear installer is telling you that installing this older version is not going to happen.

    I'm seeing this "error" too, regardless of what version of Archive_Tar is installed. The PHP installer will blindly attempt to install it's bundled versions of the pear modules irrespective of what the "pear people" think. AFAIK, this error is really a warning, and does not indicate any real problem. You very likely already have Archive_Tar 1.13 or later installed ("pear list" will tell you for sure).

    So our options on the cPanel end, is to somehow suppress this message (which will actually change nothing), hack the PHP install routines (provided by PHP) to not be so blind, or just ignore it until PHP and the "pear people" (boy I love saying that) work it out. I'm definately leaning towards the latter.

    If you want to ensure that you have the lastest version of Archive_Tar installed then run the following command through a terminal as root:
    Code:
    /usr/local/bin/pear upgrade Archive_Tar
    /usr/bin/pear upgrade Archive_Tar
    You may want to "force" the upgrade by adding "-f" after "upgrade" in the above commands if you don't see it pulling in the latest version.

    HTH
     
  6. simplestar

    simplestar Well-Known Member

    Joined:
    Nov 15, 2005
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    156
    I agree. It's been nearly 3days since I recompiled and have not had any problems, nor any error related in the logs.
     
  7. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    168
  8. tanq

    tanq Member

    Joined:
    Nov 11, 2003
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    151
    eAccelerator (0.9.4-rc1) does not seem to work with PHP 4.4.2.
     
  9. simplestar

    simplestar Well-Known Member

    Joined:
    Nov 15, 2005
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    156
    Built Jan 23, recompiled, I think Jan 26.
     

    Attached Files:

  10. pross

    pross Well-Known Member

    Joined:
    Mar 14, 2005
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    156
    no problems here...used easyapache a few days ago...
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice