The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP 5.0.3 Not Installing - Installs PHP 5.0.2!

Discussion in 'General Discussion' started by jfxberns, Dec 18, 2004.

  1. jfxberns

    jfxberns Member

    Joined:
    Dec 29, 2003
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    PHP 5.0.3 Not Installing

    PHP 5.0.3 was released today.

    I wanted to upgrade to PHP 5.0.3 as per the security alert posted on several sites.

    There is a PHP 5.0.3 option available in WHM, but it appears to install PHP 5.0.2 instead...

    I have checked the box "Version 5.0.3 (TESTING)" and run build for Apache (twice), but the output says it is making php 5.0.2 and on completion of the build, running phpinfo.php confirms that php v5.0.2 is the installed version.

    Also, there is no php-5.0.3.tar.gz file or php-5.0.3 directory in /home/cpapachebuild/buildapache.

    Clicking the "Load Previous Config" button shows that php 5.0.3 definitely was selected.

    Is tjhis a bug in WHM/BuildApache?
     
    #1 jfxberns, Dec 18, 2004
    Last edited: Dec 20, 2004
  2. cPanelBilly

    cPanelBilly Guest

    I just did a test install and all worked, possibly try running
    /scripts/easyapache
    and see if that works for you
     
  3. justinosx

    justinosx Member

    Joined:
    Jun 19, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Same Problem

    We tried to upgrade from 5.0.2 to 5.0.3 several times to no avail.... someone else had posted that 5.0.3 wasn't at layer1 (http://layer1.cpanel.net/buildapache/1/) where cpanel gets php, I can confirm that. We wget'd php from php.net to the buildapache folder on the server and had problems when it went to go test. I took the configure strings from easyapache and built it manually. Everything is working now. Also, we had strange errors when curl went to go configure in easyapache- something about could not compute size thereof or something.
     
  4. jfxberns

    jfxberns Member

    Joined:
    Dec 29, 2003
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Yes. I concur with the last post.

    Since sometime after I made the first post on Saturday, the problem changed: now cpanel does not install PHP 5.0.2, however, the build process dies after not finding php-5.0.3.tar.gz.
     
  5. irchs

    irchs Well-Known Member

    Joined:
    Jun 3, 2004
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    I can confirm that buildapache installs 5.0.3 correctly.

    Jan
     
  6. jfxberns

    jfxberns Member

    Joined:
    Dec 29, 2003
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Yes, it was fixed a few days ago.
     
  7. farmerjoe

    farmerjoe Registered

    Joined:
    Dec 14, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Every time i try to upgrade to PHP 5.0.3 my httpd service won't start. Anyone have the same experience or have any suggestions?
     
  8. brentp

    brentp Well-Known Member

    Joined:
    Mar 11, 2004
    Messages:
    324
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Ayr, North Queensland, Australia
    cPanel Support WILL NOT help you with php 5.0.3 related issues, when you ticked the box it said (TESTING) right beside it, when you install php 5.0.3 you are taking those risks. Without any error log we cannot help anyway.

    Regards,
    Brent
     
Loading...

Share This Page