The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP 5.1.4 and PHP.INI local values not bieng set

Discussion in 'General Discussion' started by Mysteerie, Jun 5, 2006.

  1. Mysteerie

    Mysteerie Well-Known Member

    Joined:
    Dec 29, 2003
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    16
    Recently got a brand new server, and upgraded to php 5.1.4. However, custom php.ini in users public_html or (sub-directories, since php.ini files only work in the folder they are in). Doesn't work.

    I cannot set any local value, and all values are set to the master value.

    Can anyone confirm that they can set a custom local value for php in php 5.1.4? If they can anyone know what could be wrong with my setup?
     
  2. tizoo

    tizoo Well-Known Member

    Joined:
    Jan 6, 2004
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    6
    Php not running as CGI ?

    Hey Mysteerie !

    Just a quick guess : Could it be that you compiled PHP as an apache module whereas you normally us it as CGI ?

    Setting parameters in php.ini in the webroot only works if PHP is compiled as CGI.

    You can easily check whether your server uses PHP as CGI by using the phpinfo() command.

    PHPSuExec also forces the use of PHP as CGI. Maybe you forgot to enable it ?

    Hope this helps, let us know if it worked.

    Best regards,
    Florian

    http://www.tizoo.com
     
  3. Mysteerie

    Mysteerie Well-Known Member

    Joined:
    Dec 29, 2003
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    16
    Server API CGI is what I'm seeing in phpinfo. Also yea forgot t mention that phpsuexec is enabled (users are running under thier own name for php scripts). Also I'm running apache 1.3.36
     
  4. Mysteerie

    Mysteerie Well-Known Member

    Joined:
    Dec 29, 2003
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    16
    Just tested this on another server, upgraded to php 5.1.4 and php.ini didn't work. The configuration file line was reading from the master php.ini and not the local one located in the user's directory. I did downgrade to php 5.0.5 and the php.ini seemed to work again in the user's directory. Though I rather find a better solution to this, anyone can point me in the right direction?
     
Loading...

Share This Page