The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP 5.2.14, Apache 2.2, FastCGI/FCGI problem, error 403 Forbidden [Case 45240]

Discussion in 'EasyApache' started by djrayon, Nov 26, 2010.

  1. djrayon

    djrayon Registered

    Joined:
    Nov 26, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hi there.

    I'm quite new on cPanel.
    I wanted to know whats wrong with my setup. I've just yesterday installed a new install of CentOS 5.5 and lates cpanel. Updated MySql to 5.1 and EasyApached the configuration Apache 2.2, PHP 5.2.14 - enabled Mod FCGI and under PHP enabled alse fcgi support. So now I can "Configure PHP and SuExec" like this for PHP5 (dont need 4):

    [​IMG]

    If I choose FCGI then even the simplest scripts (like <?php echo("foo"); ?>) will give me 403, access forbidden. It doesn't even think. Its like "magic" no "loading" just 403.

    The script and the dirs are owned by user.user (the actual user I mean). The script itself has chmod 755 (i've tryied lowering that also, but no use).

    Currently - the only thing that works is DSO, and I've heard (somewhere) that its the most "awful" way for PHP.

    Any help would be greatly appreciated.

    Thanks in advance.
     
  2. ahhyes

    ahhyes Member

    Joined:
    Dec 4, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    *bumpety bump bump bump*

    I have the same issue, same configuration as the OP, however I noticed that if I place a .php file in the cgi-bin directory then use the http://url/cgi-bin/file.php the script will run.

    Any ideas?
     
  3. ahhyes

    ahhyes Member

    Joined:
    Dec 4, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Hi Guys,

    Does anyone have a suggestion on where to even start looking for a problem like this?

    The silence is deafening.
     
  4. ehowe

    ehowe Member
    PartnerNOC

    Joined:
    Feb 19, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I'm actually working on this exact issue right now. If I find a solution, I will be sure to post it here.
     
  5. ehowe

    ehowe Member
    PartnerNOC

    Joined:
    Feb 19, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    It seems this is a problem with the Apache configuration. We were able to correct the issue by adding ExecCGI to the httpd.conf file on the server. This should also be correctable by adding "Options +ExecCGI" to the .htaccess file for your site, if you are having the same issue that I had.
     
  6. ehowe

    ehowe Member
    PartnerNOC

    Joined:
    Feb 19, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    For what it's worth, after posting this solution, I reported the issue to Cpanel, they have a bug report on the issue now, hopefully they can resolve it so that it doesn't happen in the future. I definitely verified that adding "Options +ExecCGI" to the .htaccess file in your public_html directory fixes the issue. I would be happy to help you out more if you need it though.
     
  7. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Thank you for the ticket submission; this is very much appreciated. The reported difficulty has been assigned internal case 45240 where the issue is being examined further.
     
  8. ahhyes

    ahhyes Member

    Joined:
    Dec 4, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Thank god it isn't just me with the issue. When there is an official explanation/solution for this case, would someone mind posting it here?
     
  9. ehowe

    ehowe Member
    PartnerNOC

    Joined:
    Feb 19, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Once my ticket with cPanel was resolved, they informed me that the fix will be in the next release of cPanel/WHM/EasyApache. The recommended fix was that you add 'Options +ExecCGI' to the .htaccess file for the site. They will be setting this as default in the next release.
     
  10. coolrunning

    coolrunning BANNED

    Joined:
    Oct 19, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    I have the same issue, same configuration as the OP, however I noticed that if I place a .php file in the cgi-bin directory then use the http://url/cgi-bin/file.php the script will run.

    Any ideas?
     
  11. ahhyes

    ahhyes Member

    Joined:
    Dec 4, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    That worked for me :)
     
Loading...

Share This Page