The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

php 5.2.4 default - need php4.4 for some sites.

Discussion in 'General Discussion' started by neonix, Oct 16, 2007.

  1. neonix

    neonix Well-Known Member

    Joined:
    Oct 21, 2004
    Messages:
    124
    Likes Received:
    2
    Trophy Points:
    0
    Hi,

    I had php v 4.4.4 running and upgraded thorough easyapache after choosing the "load existing build option" - but the upgrade has also installed php v 5.2.4 and made it the default option which is causing major headaches for a few sites.

    I presume both php4 and php5 versions are on the server.

    I have tried making PHP4 the default option under WHM but all the php sites stopped working and had to revert back to PHP5.

    How do I make the few problem sites work under php 4.4.4. and not php 5.2.4 -

    Thanks for your advise.
     
  2. lostinspace

    lostinspace Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    122
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Colorado Springs, CO
    First, ensure you select the build option for both PHP versions.

    Then each site needing PHP 4.x will need to rename their php extensions to php4. You can probably achieve easier results using an htaccess file to set the file extensions.
     
Loading...

Share This Page