PHP 5.2.4 released to Apache Update

roba

Member
Jan 20, 2004
12
0
151
Prague, CZ
cPanel Access Level
Root Administrator
Be careful with this option. I just used it to upgrade PHP from 4.4.7 and it installed 4.4.7 again, but configured Apache to use 5.2.4 (I guess), so the webserver was outputing source code of all PHP files instead of parsing them! :mad: I hope there were no random visitors while I was reverting.

Now I used Apache update with 5.2.3 and it worked well.


WHM 11.2.0 cPanel 11.11.0-R16789
CENTOS Enterprise 4.4 i686 - WHM X v3.1.0
 

dav

Registered
Apr 30, 2005
1
0
151
Manchester, UK
Hmmm, I just checked my Apache Build page and my PHP options go up to 5.2.3 not 5.2.4.

I have just ran the Update to latest version which is 11.11.0-STABLE_16908

Any reason why I can't see the latest version of PHP?
 

DReade83

Well-Known Member
Oct 20, 2006
196
0
166
Cheshire, UK
I'm running CURRENT - that may have something to do with it, although I didn't think it would. PHP 5.2.4 has been built and is running without a problem here.
 

MauricioBR

Registered
Apr 3, 2007
3
0
151
Be careful with this option. I just used it to upgrade PHP from 4.4.7 and it installed 4.4.7 again, but configured Apache to use 5.2.4 (I guess), so the webserver was outputing source code of all PHP files instead of parsing them! :mad: I hope there were no random visitors while I was reverting.
That happened to me too when I was updating from PHP 4.x to 5.x (months ago), but PHP started parsing the pages when the update finished.
Fortunately my pages were encoded with ZendGuard :P

Hmmm, I just checked my Apache Build page and my PHP options go up to 5.2.3 not 5.2.4.
I think it's not available in STABLE yet, but it is in RELEASE.
 
Last edited:

Lazek

Well-Known Member
Mar 7, 2007
141
0
166
cPanel Access Level
Root Administrator
At updating with PHP 5.2.3 on PHP 5.2.4 there is a mistake:
./configure [@libxml2-2.6.22]...(--prefix=/usr).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done

make [@libxml2-2.6.22]...(-j 1).... Done

1 error

Prompt how to correct ?
 

cooldude7273

Well-Known Member
Jan 11, 2004
359
0
166
Roswell, GA
First time I compiled with 5.2.4, the actual compile showed 4.4.7, but phpinfo said it was still 5.2.3.

Recompiled again, same options with 5.2.4, and everything worked as expected.

Can anyone else confirm it takes two times to upgrade?