The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP 5.2.9 inclusion

Discussion in 'General Discussion' started by escalf, Feb 28, 2009.

  1. escalf

    escalf Member
    PartnerNOC

    Joined:
    Sep 30, 2006
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    PHP release 5.2.9 on 26 FEB. Is there any timeline for inclusion of this version in easyapache? 5.2.9 addresses significant vulnerabilities and memory handling issues present in 5.2.8 and previous.

    Thanks.
    -Eric S.
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    We prefer to implement support for new PHP releases ASAP. It will likely be available as soon as we can get it through our quality assurance process. I have no precise ETA on this, but I do see the developers are actively working on adding PHP 5.2.9 support to EasyApache.
     
  3. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    PHP 5.2.9 is available as of EasyApache build 4624.
     
  4. Gene Steinberg

    Gene Steinberg Well-Known Member

    Joined:
    May 26, 2007
    Messages:
    157
    Likes Received:
    1
    Trophy Points:
    18
    I performed the update on two servers, along with the latest RELEASE build, without incident. But I agree with you that one should request assistance if you're not sure which options to check in Easy Apache, and you don't just want to use the settings you have.

    Peace,
    Gene
     
  5. alyssa

    alyssa BANNED

    Joined:
    Mar 5, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Ok, got past the FastCGI issue now. Need 2 hotfixes + PHP 5.2.6 win32 and will document the procedure once (if) I get this installed.

    All the checks passes in cerb4-servercheck.php

    Now moving to the install I get this which looks like a Pear issue
     
Loading...

Share This Page