The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP 5.3.1 and 5.2.12

Discussion in 'General Discussion' started by paszczak000, Dec 29, 2009.

  1. paszczak000

    paszczak000 Active Member

    Joined:
    Nov 29, 2007
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Poland, Łódź
    Hello,
    it is possible to run every page on server at PHP 5.3.1 and one page at 5.2.12?
    Because I have a lot of error:
    Code:
    PHP Fatal error:  Invalid opcode 227/2/8
    PHP Fatal error:  Invalid opcode 136/2/8
     
  2. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    You can add a handler in a .htaccess file to use a specific PHP version for the files residing in the directory itself. However, you cannot make every page run on both the PHP versions.

    BTW, I would recommend you to use PHP 5.2.x server wide as PHP 5.3.x is having a lots of bug. It has been said that they are resolved but many should still be there.
     
Loading...

Share This Page