donald22

Member
Sep 6, 2013
10
0
1
cPanel Access Level
Root Administrator
Hi, I have/had two cpanel based servers, one that I still have runs the latest php 5.4.9 with several php 5.4 ready websites and everything is fine but I also have 3 Vbulletin 4X forums that will not run on php 5.4 and for some reason cpanel is only offering those of us with scripts that will only run on php 5.3 the depricated 5.3.27 version and for some time now someone has been knocking my sites out, like all the sites would go down vb database errors etc but cpanel still up so you would reboot the server and everything is ok again but this was happening 2-3 times daily, while other php 5.4 server is fine and in the end had to change to your rival Plesk that runs php 5.3.3 and everything is fine now. What is your advice for scripts that can only run php 5.3? and if I am not mistaking is this not vb 4? How do you get round the depricated php problem. Surely not Plesk?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
Hello :)

Are you attempting to run multiple versions of PHP 5 on the server? There is no support for that at this time, however there is an open feature request at:

Multiple PHP 5.x Installations

To note, there are third-party applications that allow for this. For example, Cloud Linux offers the PHP Selector feature.

Thank you.
 

donald22

Member
Sep 6, 2013
10
0
1
cPanel Access Level
Root Administrator
No that is not the issue, the issue is that php 5.3.27 is depricated and not safe, what is your advice for those of us that have scripts (eg vbulletin 4X) that will only run on php 5.3?
 

dalem

Well-Known Member
PartnerNOC
Oct 24, 2003
2,977
152
368
SLC
cPanel Access Level
DataCenter Provider
bug vbulletin to get off their lazy you know what and update their scripts it was not a mystery that php 5.3 would be EOL

note: depricated 5.3.27 does not mean that its bad it means that its EOL it i still the latest version plesk would be running the same php
 

ThinIce

Well-Known Member
Apr 27, 2006
352
9
168
Disillusioned in England
cPanel Access Level
Root Administrator
I'm not aware of anything specifically targetting php 5.3.27 at the mo, whilst it's been declared that it is reaching end of life it will receive security patches until the middle of next year

PHP: News Archive - 2013

It's conjecture, but I guess there was something specific to your old server (i.e. it / an account on it had been compromised in some way) or your sites on it were being brought down through some simple dos tactic...

This for example was relatively recent Potential vBulletin Exploit (4.1+ and 5+) | Sucuri Blog
 

donald22

Member
Sep 6, 2013
10
0
1
cPanel Access Level
Root Administrator
Thanks for the replies, no I never keep install directories in place. I think it is too much of a coincidence that that the exact same forums, imported through transfer manager are running just fine on Plesks more up to date version of php5.3.3. I share the blame equally between vbulletin who refuse to update their software to run on php 5.4 imo in the hope you will splash out on their latest vbulletin 5. and cpanel for as you put it :D being too lazy to have easyapache update to php5.3.3 instead of 5.3.27.
 

quietFinn

Well-Known Member
Feb 4, 2006
1,222
87
178
Finland
cPanel Access Level
Root Administrator
Thanks for the replies, no I never keep install directories in place. I think it is too much of a coincidence that that the exact same forums, imported through transfer manager are running just fine on Plesks more up to date version of php5.3.3. I share the blame equally between vbulletin who refuse to update their software to run on php 5.4 imo in the hope you will splash out on their latest vbulletin 5. and cpanel for as you put it :D being too lazy to have easyapache update to php5.3.3 instead of 5.3.27.
I think you are mistaken, 5.3.27 is much newer version than 5.3.3