PHP 7.3.7, ImageMagick7 & PHP-Brotli Availability

The Old Man

Well-Known Member
Feb 24, 2016
80
21
58
UK
cPanel Access Level
Root Administrator
Hello,

Please could you advise when PHP 7.3.7 will be made available via the WHM updater?
My VPS sites are plagued with intermittent random 503 errors caused by a bug in 7.3.6 and 7.3.7 has been confirmed to resolve it with a specific bug fix.

Secondly, to save a lot of time and if possible, please could you consider adding the PHP-Brotli extension to those available in the PECL installer feature? Supposedly it is available via Remi RPM's but like PHP 7.3.7, it never shows as available whenever I search RPM's, possibly because the Remi mirrors are outdated.

Lastly, is it possibly you could add support for installing ImageMagick 7, as v6 is considered legacy. I noticed that the version mentioned in the forthcoming WHM Version 82 release notes today seems to be an older version of v6 (6.7.8.9-16.el7_6) than on their website (6.9.10-53) at ImageMagick - Convert, Edit, Or Compose Bitmap Images

Many thanks.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,298
1,279
313
Houston
Hi @The Old Man


We're actually planning an easyapache update today that will include updates to PHP including php 7.3.7 - which was just released last week on a holiday.

Brotli should be available through EasyApache/Using Yum:
Code:
# yum search brotli
Loaded plugins: fastestmirror, universal-hooks
Loading mirror speeds from cached hostfile
 * EA4: 70.87.220.252
 * EA4-experimental: 70.87.220.252
 * cpanel-addons-production-feed: 70.87.220.252
 * cpanel-plugins: 70.87.220.252
 * base: centos.den.host-engine.com
 * centosplus: repos.dfw.quadranet.com
 * epel: mirror.dal.nexril.net
 * extras: mirror.dal10.us.leaseweb.net
 * updates: mirror.wdc1.us.leaseweb.net
================================================================================= N/S matched: brotli ==================================================================================
ea-apache24-mod_brotli.x86_64 : Compress content via Brotli before it is delivered to the client
ea-brotli.x86_64 : Brotli compression format
ea-brotli-debuginfo.x86_64 : Debug information for package ea-brotli
ea-brotli-devel.x86_64 : Header files and development libraries for ea-brotli
brotli.x86_64 : Lossless compression algorithm
brotli-devel.x86_64 : Lossless compression algorithm (development files)
python36-brotli.x86_64 : Lossless compression algorithm (python 3)

  Name and summary matches only, use "search all" for everything.

As far as ImageMagick goes we don't ship that, it's provided by the OS so whatever package is offered by your OS is what you'll be able to install by default.

ON CentOS 7 I have:

Code:
Name        : ImageMagick
Arch        : x86_64
Version     : 6.7.8.9
Release     : 16.el7_6
Size        : 7.6 M
Repo        : installed
From repo   : updates
Summary     : An X application for displaying and manipulating images
URL         : http://www.imagemagick.org/
License     : ImageMagick
Description : ImageMagick is an image display and manipulation tool for the X
            : Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
            : and Photo CD image formats. It can resize, rotate, sharpen, color
            : reduce, or add special effects to an image, and when finished you can
            : either save the completed work in the original format or a different
            : one. ImageMagick also includes command line programs for creating
            : animated or transparent .gifs, creating composite images, creating
            : thumbnail images, and more.
            :
            : ImageMagick is one of your choices if you need a program to manipulate
            : and display images. If you want to develop your own applications
            : which use ImageMagick code or APIs, you need to install
            : ImageMagick-devel as well.
 
  • Like
Reactions: The Old Man

The Old Man

Well-Known Member
Feb 24, 2016
80
21
58
UK
cPanel Access Level
Root Administrator
Hi Lauren,

Thank you. I got the update to PHP 7.3.7 and the pesky 503 errors have indeed gone.

Thanks for the clarification on ImageMagick7.

Sorry for the confusion, I too get similar Yum search results for Brotli but had assumed from the listing that they didn't include the PHP-Brotli extension, that they were the Python plug-in and the Apache module mod_brotli instead. The author states on his site:

RPM packages of this extension are available in » Remi's RPM repository and are named php-brotli.
Thanks again.
 
  • Like
Reactions: cPanelLauren

Signofgrey

Registered
Oct 23, 2019
1
0
1
Sweden
cPanel Access Level
Root Administrator
Hi,

Excuse me for being thick. But from the results of
Code:
 yum search brotli
, I can't seem to figure out which one of the avaliable installations that actually enables php-brotli on Centos 7.

Did you actually manage to enable it, or did I missunderstand both of your answers?

Thanks in advance,
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,298
1,279
313
Houston
Actually, it wasn't clear here before and to clarify, we have mod_brotli the apache module available in EA4 as ea-apache24-mod_brotli.x86_64 but we do not offer php-brotli.

There have been some requests for this, the following thread goes over one potential solution and some really fantastic information:


There's also a feature request which would include php-brotli: