vacancy

Well-Known Member
Sep 20, 2012
469
163
93
Turkey
cPanel Access Level
Root Administrator
Hello

I see this error when I want to install opcache for php 8.0 with Easyapache 4.

Code:
Error: Package: ea-php80-php-opcache-8.0.0-2.2.2.cpanel.x86_64 (EA4)
    Requires: ea-php80-php-cli(x86-64) = 8.0.0-2.2.2.cpanel
    Installed: ea-php80-php-cli-8.0.0rc4-4.6.1.cpanel.x86_64 (@EA4-experimental)
        ea-php80-php-cli(x86-64) = 8.0.0rc4-4.6.1.cpanel
    Available: ea-php80-php-cli-8.0.0-2.2.1.cpanel.x86_64 (EA4)
        ea-php80-php-cli(x86-64) = 8.0.0-2.2.1.cpanel
    Available: ea-php80-php-cli-8.0.0-2.2.2.cpanel.x86_64 (EA4)
        ea-php80-php-cli(x86-64) = 8.0.0-2.2.2.cpanel
Error: Package: ea-php80-php-opcache-8.0.0-2.2.2.cpanel.x86_64 (EA4)
    Requires: ea-php80-php-common(x86-64) = 8.0.0-2.2.2.cpanel
    Installed: ea-php80-php-common-8.0.0rc4-4.6.1.cpanel.x86_64 (@EA4-experimental)
        ea-php80-php-common(x86-64) = 8.0.0rc4-4.6.1.cpanel
    Available: ea-php80-php-common-8.0.0-2.2.1.cpanel.x86_64 (EA4)
        ea-php80-php-common(x86-64) = 8.0.0-2.2.1.cpanel
    Available: ea-php80-php-common-8.0.0-2.2.2.cpanel.x86_64 (EA4)
        ea-php80-php-common(x86-64) = 8.0.0-2.2.2.cpanel
The entire output was logged to: /usr/local/cpanel/logs/packman/errors/2020-12-09_21:03:28-1
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
6,998
922
313
cPanel Access Level
Root Administrator
Hey man,

I couldn't reproduce this one on my end. When the ea-php80 package is installed it also does these packages as part of the initial dependencies:

Code:
Running transaction
  Installing : ea-php80-runtime-8.0.0-2.2.1.cpanel.x86_64                                                                                                                                                     1/10
  Installing : ea-php80-php-common-8.0.0-2.2.2.cpanel.x86_64                                                                                                                                                  2/10
  Installing : ea-php80-php-litespeed-8.0.0-2.2.2.cpanel.x86_64                                                                                                                                               3/10
  Installing : ea-php80-php-cli-8.0.0-2.2.2.cpanel.x86_64                                                                                                                                                     4/10
  Installing : ea-php80-php-ftp-8.0.0-2.2.2.cpanel.x86_64                                                                                                                                                     5/10
  Installing : ea-php80-php-xml-8.0.0-2.2.2.cpanel.x86_64                                                                                                                                                     6/10
  Installing : ea-php80-php-devel-8.0.0-2.2.2.cpanel.x86_64                                                                                                                                                   7/10
  Installing : ea-php80-php-posix-8.0.0-2.2.2.cpanel.x86_64                                                                                                                                                   8/10
  Installing : ea-php80-pear-1.10.12-1.1.2.cpanel.noarch                                                                                                                                                      9/10
  Installing : ea-php80-8.0.0-2.2.1.cpanel.x86_64
so the cli package is in place from the start. Can you try a reinstall of the main ea-php80 package to see if that takes care of things?