adam5532

Member
Feb 14, 2009
7
0
51
Hi,
After configuring everything in Apache for UTF-8 and being baffled why my pages still showed Windows and ISO character sets, I finally realized that I had to set UTF-8 in PHP also.

So, I added default_charset = "utf-8" to my /usr/local/lib/php.ini and that fixed it!

What do I need to do to make sure that this change isn't overwritten when I run EasyApache the next time, and why with all the multitude of setting options available in WHM is the character set not something that can be chosen and set through the UI?

Thanks,
Adam
 

adam5532

Member
Feb 14, 2009
7
0
51
It looks like I already had that set to utf-8. But it was not until I manually added default_charset = "utf-8" to my php.ini file that it actually worked. A search does not find any other entry for utf-8 or charset in the ini file. Any ideas why?
Thanks, Adam
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hello :)

You can make changes to the /usr/local/lib/php.ini file via:

"WHM Home » Service Configuration » PHP Configuration Editor"

Adjusting the "default_charset" value via this option will update the php.ini file accordingly. Remember to restart Apache after making the change to ensure it takes effect. Could you be more specific about what specific value you are expecting to see in the php.ini file that does not exist?

Thank you.