Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

PHP compilation failure -> need help!!!

Discussion in 'General Discussion' started by KimBO, Oct 25, 2005.

  1. KimBO

    KimBO Well-Known Member

    Joined:
    Sep 2, 2004
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    156
    Hello!

    we have a new Server with Fedora Core 4 in the minimal installation. After this we installed cpanel (RELEASE) WHM 10.8.0 cPanel 10.8.1-R4.

    As we tried to compile the webserver to php5 with suPHP we got very much error messages (see attachment - but not all, there were more than 2600 :D )...

    After this we wanted to compile Apache with php4.4 with suPHP. The run was without any errors, but no php pages can run now...

    In /usr/local/apache/htdocs is a phpinfo.php with only shows phpinfo()... if I look at http://mydomain.com/phpinfo.php I only get an error 500....

    This is in our http.conf:
    <Directory "/usr/local/apache/htdocs">
    Options FollowSymLinks Includes ExecCGI
    </Directory>

    If I log at the error log:

    Tue Oct 25 11:48:21 2005] [error] (22)Invalid argument:
    setrlimit(RLIMIT_AS): failed to set memory usage limit
    [Tue Oct 25 11:48:21 2005] [error] (13)Permission denied: exec of
    /usr/local/apache/htdocs/phpinfo.php failed
    [Tue Oct 25 11:48:21 2005] [error] [client XXX.XXX.XXX.XXX] Premature end
    of script headers: /usr/local/apache/htdocs/phpinfo.php
    [Tue Oct 25 11:48:21 2005] [error] [client XXX.XXX.XXX.XXX] File does not
    exist: /usr/local/apache/htdocs/500.shtml

    I found in the forum in WHM -> Tweak Settings -> 'The maximum memory a cPanel process can use
    before it is killed off' - our is set at 196 MB.

    Who can help us? The optimal solution would be php5 with suPHP (ok, maybe without suPHP), but php4.4 with suPHP is not a solution....

    THANKS FOR YOUR HELP!!!

    Greetings...

    KimBO
    :D
     

    Attached Files:

  2. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    166
    Why are you messing around with suphp? Wouldnt it be easier just to compile using phpsuexec and php 4.3.11?

    Iv read those howto's for suphp and when i asked the author of the howto a few questions about it they told me they have since DISABLED it completely because they were having all kinds of problems with suphp.
     
  3. ecwebtechie

    ecwebtechie Well-Known Member

    Joined:
    Mar 22, 2005
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    156
    you created phpinfo.php, change the ownership to user apache and try
     
    #3 ecwebtechie, Oct 25, 2005
    Last edited: Oct 26, 2005
  4. PanelGuy

    PanelGuy Well-Known Member

    Joined:
    Oct 13, 2004
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    166
    pjpinfo.php

    CHANGE PERMISSIONS OR CHANGE OWNERSHIP? Two different amnimals and a huge difference in effect.
     
  5. KimBO

    KimBO Well-Known Member

    Joined:
    Sep 2, 2004
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    156
    Thanks for your replies. But this makes me a little bit confuse... is suPHP not the same like phpsuexec?

    My main problem is, that I cannot fix apache with php5! First I have changed everything back to php4.4 - and then I only activated the check box for php5, but I get the same error messages like in the first posting...

    Is there a packages missing or should I get a new tgz of lbxml2 and then install it into the apache folder?

    I really confused and helpless.... :confused:

    Greetings and thanks for help!!!

    KimBO
    :D
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice