The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

php configuration editor problem

Discussion in 'General Discussion' started by myweb, Feb 23, 2008.

  1. myweb

    myweb Well-Known Member

    Joined:
    Jun 18, 2002
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Tokyo
    php configuration editor saves php.ini in which extra spaces are added to some directive values as below:

    session.save_handler = "files "

    the above one caused a problem that a php web application namely XOOPS were unable to override the session save handler using the php session_set_save_handler() function, causing no session being saved thus nobody being able to login (XOOPS needs to use DB to save session data). I modified the above directive manually as below and all started to work again as usual.

    session.save_handler = "files"

    why does the editor add extra spaces to the directive values? will this be fixed in the future releases?
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
  3. jamiemcd

    jamiemcd Registered

    Joined:
    Aug 29, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I really hope this gets fixed soon (the original bug report was in October of 2007). I just had this happen to me. I used WHM's PHP Configuration Editor in advanced mode to bump up one setting from 32 to 64. But by using the editor, it also added spaces to several other settings that I didn't change.

    For example:

    Code:
    session.serialize_handler ="php"
    became

    Code:
    session.serialize_handler = "php     "
    which of course broke all the pages using php sessions.
     
    #3 jamiemcd, Apr 22, 2008
    Last edited: Apr 22, 2008
  4. deborahgsmith

    deborahgsmith Member

    Joined:
    May 18, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    SE Michigan
    This is still a problem on our servers.

    I modified the php.ini via the WHM Php Configuration Editor and it put spaces in these two variables:

    session.serialize_handler ="php "
    session.save_handler = "files "

    http://bugzilla.cpanel.net/show_bug.cgi?id=6060

    I see the bug has been marked as fixed/resolved in the bug report:

    <snip>
    ------- Comment #4 From Kenneth Power 2008-05-28 14:26 [reply] -------

    This is fixed in the 11.23 series.
    </snip>

    Our servers are running the following release:

    WHM 11.23.2 cPanel 11.23.3-R25971
    CENTOS Enterprise 4.6 i686 on virtuozzo - WHM X v3.1.0

    Can someone clarify?

    Thanks!

    Deborah Smith
    Server and Technical Support
    San Francisco Host
     
  5. deborahgsmith

    deborahgsmith Member

    Joined:
    May 18, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    SE Michigan
    Bug 7157 Submitted
     
Loading...

Share This Page