The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP Error

Discussion in 'General Discussion' started by mickalo, Apr 5, 2016.

  1. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    Hello,

    We have a customer who is getting the following PHP error:
    Code:
    Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20100525/suhosin.so
    
    We're running PHP v. 5.5 currently. It's been awhile since we've had any issues with PHP so not sure what would be causing this problem. Any assistance would be appreciated

    Thanks,
    Mike
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,814
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  3. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa

    No they don't. But I ran that utility script on the server to install PHPSuhosin now I get the follow error:
    Code:
    PHP Fatal error:  The file
    /home/decision/public_html/UltimateFooterAd/index.php was encoded by
    the
    ionCube Encoder for PHP 4 and cannot run under PHP 5.5 or PHP 5.6.
    Please ask the provider of the script to provide a version encoded with
    the ionCube Encoder for either PHP 5.3 or PHP 5.4 or PHP 5.5'
    
    So I assume their PHP is out dated and won't work unless they update their scripts correct?

    Thanks,
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,814
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Could you provide more details on the utility script you are referring to?

    Yes, assuming you do not want to downgrade your version of PHP, the script should be updated to support newer versions of PHP.

    Thank you.
     
  5. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    the script I used to install
    Code:
    /scripts/phpextensionmgr install PHPSuHosin
    
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,814
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    This is a valid method of installing Suhosin for PHP. If you use PHP 5.4 or above, EasyApache uses Suhosin 0.9.36. If you use PHP 5.3, EasyApache uses Suhosin 0.9.33. As mentioned, the error message you provided after installing Suhosin suggests the issue relates to the age of the script and the version of PHP.

    Thank you.
     
Loading...

Share This Page