The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

php error

Discussion in 'General Discussion' started by SharpeNews, Mar 18, 2007.

  1. SharpeNews

    SharpeNews Registered

    Joined:
    Mar 18, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hi All,

    We have recently purchased a new dedicated server and set it up and everything.

    When our dns protergates and allows people to go on the new server. We have some php errors.

    SharpeNews

    Warning: main(http://www.sharpenews.co.uk/adverts.php) [function.main]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in /home/sharpene/public_html/sn/includes/header.php on line 4

    Warning: main() [function.include]: Failed opening 'http://www.sharpenews.co.uk/adverts.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/sharpene/public_html/sn/includes/header.php on line 4

    Warning: main(http://www.sharpenews.co.uk/right_adverts.php) [function.main]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in /home/sharpene/public_html/sn/index.php on line 669

    Warning: main() [function.include]: Failed opening 'http://www.sharpenews.co.uk/right_adverts.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/sharpene/public_html/sn/index.php on line 669

    Warning: file_get_contents(http://www.sharpenews.co.uk/lockdown...n-mainsite.txt) [function.file-get-contents]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in /home/sharpene/public_html/sn/includes/config.php on line 34

    I know its due to a too high php version for the scripts on the site. How do i change my php version in WHM?

    I checked both servers and both servers are running php 4
     
  2. SharpeNews

    SharpeNews Registered

    Joined:
    Mar 18, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I would be greatfull if someone could help me
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    What version of PHP do you want to use? You should run anything lower that PHP v4.4.6 or v5.2.1 due to the myriad of security flaws.
     
  4. jaizkris

    jaizkris Member

    Joined:
    Mar 4, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    You can change the php from WHM.

    Select the softwares in WHm.

    There select the apache updates. Here you can select the version of php you want.

    Do you need any futher assistance.
     
Loading...

Share This Page