Carl Beebe

Member
Jun 1, 2017
9
2
3
Colorado
cPanel Access Level
DataCenter Provider
One Of My Customers Is Getting The Error:
Code:
PHP Fatal error:  Cannot re-assign auto-global variable _POST in /home/************/public_html/music/index.php on line 9549
According To My Research - This Is Because Of Depreciated PHP Commands - This Software The Customers Is Trying Uses & Recommends
(PHP4 or PHP5). PHP 5 is recommended
The Server Has 5.5 | 5.6 & 7.0 Installed - Default Version For Server Is 5.6

Any Ideas
 

sktest123

Well-Known Member
Jan 31, 2017
99
6
8
kochin
cPanel Access Level
Root Administrator
bit of coding stuff.friend, as this is what I got
"
Since PHP 5.4, you cannot use a superglobal as the parameter to a function, $_POST is globally accessible. So you don't have to pass to your function"
Just vi file +9549 and try checking removing the POST variable.
Have a backup of file first
 
  • Like
Reactions: 24x7serversecurity

Jcats

Well-Known Member
PartnerNOC
May 25, 2011
806
156
168
New Jersey
cPanel Access Level
DataCenter Provider
You would need to use PHP 5.3 as apparently its functionality was removed in PHP 5.4

PHP: Superglobals - Manual

Just Google "Cannot re-assign auto-global variable _POST" there are a bunch of hits, some of which may help you to change the code up a bit to resolve it.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
Hello,

I'm happy to see the issue is now addressed. Thank you for updating us with the outcome.