Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

php form emails going into default email account

Discussion in 'E-mail Discussion' started by fullfatdesigns, Oct 21, 2014.

  1. fullfatdesigns

    fullfatdesigns Well-Known Member

    Joined:
    Aug 1, 2014
    Messages:
    58
    Likes Received:
    9
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    We have a website hosted on our server with the domain and email hosted elsewhere. The email works fine, except for when a php form is submitted and instead of going to the regular email server it goes into the default email account on the server.

    Is there something I need to do to avoid this and go to the correct mail server? As I'm guessing if I change the default email to Fail, the form results will bounce back?

    Thanks
    Wayne
     
  2. fullfatdesigns

    fullfatdesigns Well-Known Member

    Joined:
    Aug 1, 2014
    Messages:
    58
    Likes Received:
    9
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    I tried a few different options...

    I've go into Default Address and under Set Default Address, I've tried setting this to Discard with error to sender and also Forward to email address. Both have the same result of going into the default mailbox as an undeliverable mail error.

    Has anyone got a few more suggestions I can try?

    Thanks
    Wayne
     
  3. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,435
    Likes Received:
    1,961
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    Please ensure you select "Remote Mail Exchanger" under "Email Routing" for the domain name via "WHM Home » DNS Functions » Edit DNS Zone" or "cPanel - MX Entry".

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. fullfatdesigns

    fullfatdesigns Well-Known Member

    Joined:
    Aug 1, 2014
    Messages:
    58
    Likes Received:
    9
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Hi Michael

    Thank you, this was the issue. My default it was selecting the local option when setting up. You have saved me a lot of stressful hours! Thanks again

    Wayne
     
  5. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,435
    Likes Received:
    1,961
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    I am happy to see the issue is now resolved. Thank you for updating us with the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice