SOLVED php-fpm disable error log for a single account

Skin

Well-Known Member
Feb 3, 2006
93
4
158
Italy
Hello,

I have an old site that is creating a very big error log in few minutes, each page visit creates a lot of php error log lines .

I`m running cPanel 70.0.48 and php-fpm is enabled on this account.

I`d like to disable error log only for this account, so I edited /var/cpanel/userdata/[USER]/[DOMAIN].php_fpm.yaml and inserted:
Code:
 php_value_error_reporting = 0

but after running
/usr/local/cpanel/scripts/php_fpm_config --rebuild
and restarting php-fpm
the error log is still increasing rapidly.

Can you please help?
 
Last edited:

Skin

Well-Known Member
Feb 3, 2006
93
4
158
Italy
I found the solution, I write it here so it can be useful to other people, in practice I was wrong to write
php_value_error_reporting = 0

After putting
Code:
php_value_error_reporting: 0
in /var/cpanel/userdata/[USER]/[DOMAIN].php_fpm.yaml , and after running
/usr/local/cpanel/scripts/php_fpm_config --rebuild
the error log was disabled as expected.
 
  • Like
Reactions: cPanelLauren