justinC

Registered
Jul 15, 2016
2
1
3
Huntington Beach, CA
cPanel Access Level
Root Administrator
Sorry, I'm a noob. I would like the reverse setup of what the OP describes in this post: Changing PHP-FPM error_log location

Right now my php error_logs are getting generated in the same directory as the PHP file that generated the error, but I would prefer having them in the following path for all domains (VirtualHosts?) hosted on the server:

/home/username/logs/domain_tld.php.error.log

The OP in the post I linked to stated that this is the default error_log location for PHP_FPM. As far as I can tell, I have php-fpm enabled (well, at least PHP-FPM service for Apache is checked of as enabled in the Service Manager in WHM, not sure if that is enough? phpinfo() shows CGI/FastCGI as the Server API).

For what it's worth, I do not have any .yaml files in /var/cpanel/userdata/user/
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
As far as I can tell, I have php-fpm enabled (well, at least PHP-FPM service for Apache is checked of as enabled in the Service Manager in WHM, not sure if that is enough? phpinfo() shows CGI/FastCGI as the Server API).
Hello,

You need to enable PHP-FPM for each domain name via "WHM >> MultiPHP Manager" or use the "System PHP-FPM Status" option in MultiPHP Manager to turn it on for all accounts.

Thank you.