Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED PHP-FPM for cpsrvd Fails

Discussion in 'General Discussion' started by dstana, Dec 14, 2016.

  1. dstana

    dstana Well-Known Member

    Joined:
    Jul 6, 2016
    Messages:
    64
    Likes Received:
    8
    Trophy Points:
    8
    Location:
    Phoenix, AZ
    cPanel Access Level:
    Root Administrator
    Upon checking the status of services on my server I noticed cpanel_php_fpm is down. Upon trying to restart the service I get the following error:

    "ERROR: unable to allocate 1168 bytes in shared memory: Cannot allocate memory: Cannot allocate memory (12)"

    I've got 64gb of memory available on the server, a small fraction is used at any given time. I set the cPanel Process memory to 2048mb in the Tweak Setting section of the server and service still fails to start with the same error code.

    Is there somewhere else I should be looking to allocate more resources so this process can run?
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,532
    Likes Received:
    1,966
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @dstana,

    Please run the following command and let us know of any error messages in the output:

    Code:
    /scripts/restartsrv_cpanel_php_fpm  --start & tail -f /var/log/messages
    Also, could you verify which version of cPanel is installed on this system?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice