The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP function not working well

Discussion in 'General Discussion' started by fatepower, Nov 4, 2007.

  1. fatepower

    fatepower Registered

    Joined:
    Nov 3, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi ppls :)

    Hoply someone can help me with this error.
    I run a CentOS 5 server with WHM/Cpanel, the problem is when a user on my host use the function "move_uploaded_file" they get written in the uploaded dir with the permission 600 and not 644 as they should be. Yea i know that this can be fixed with a chmod(); function added into the script. But thats not a good solution cuz my host users want to use their scripts and i can't say all the time edit the source code and add a chmod(); function for the file uploads so they get chmod 644 permission after upload. I now that this can be solved in some way, my old server was a managed server and all was pre-installed and there the "move_uploaded_file();" function worked well with writing the files in to the upload-dir with chmod 644, but for me on this server it writes the uploaded file with the permission of 600 :/.

    Does anyone know?

    Cheers
     
    #1 fatepower, Nov 4, 2007
    Last edited: Nov 4, 2007
  2. KirillProninesp

    KirillProninesp Registered

    Joined:
    May 17, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    The problem on the former is actual.
    There are variants of its decision?
     
  3. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page