The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP +GD, where is the .so?

Discussion in 'General Discussion' started by jozeph, Jun 10, 2004.

  1. jozeph

    jozeph Well-Known Member

    Joined:
    Apr 16, 2004
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    Hi everybody,

    I have compiled my Apache+PHP+etc more then 3 times, and all times PHP+GD is not working very well.

    In the phpinfo, GD status is enabled, but when I try to use some applications with: imagecreatefromjpeg function, it´s not working.

    I have re-installed the last time using ./easyapache script options 5.

    Before I used it, from WHM and choosing all options libs there I think necessary.

    My /etc/php.ini havent php_gd.so extension and /usr/lib/php4 only have: mysql.so, imap.so and ldap.so.
     
  2. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    the .so files are at : /usr/local/apache/libexec/ folder for apache.. if you can be a bit more specific .. as to what all you want.. i can be of more help.
     
  3. JUVE_tHa_great

    JUVE_tHa_great Registered

    Joined:
    Jun 20, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    ok im new to this cpanel stuff and i was been trying to figure out how to get that cpanel error page to become my site. i dont know which folder my index.html should go for it to work. plz help
     
  4. rodstewart

    rodstewart Active Member

    Joined:
    Feb 4, 2004
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hamburg Germany
    cPanel Access Level:
    DataCenter Provider
    has anyone find a solution to install this file? Becuase many of my cusomers get this error message.

    PHP Warning: Unknown(): Unable to load dynamic library './php_gd.so' - ./php_gd.so: cannot open shared object file: No such file or directory in Unknown on line 0
     
  5. tsook

    tsook Well-Known Member

    Joined:
    Mar 21, 2003
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    6
    Have you mamaged to solve this problem?
     
  6. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    If you do things on your own without knowing the technical consequences, you might do more damage to your server. Please, hire a sys admin.
     
  7. rodstewart

    rodstewart Active Member

    Joined:
    Feb 4, 2004
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hamburg Germany
    cPanel Access Level:
    DataCenter Provider
    Nice answer AndyReed

    We have enough poeples like you who say bla bla bla.
    It will be better to help each other. Every one has beginning some time. And you too.
    And many peoples have help you before you stay on you position on that you are now.

    tsook if you have this problem contact me via Email or PM and i will help you.
    AND THAT FOR FREE!!! :)

    ciao Rod
     
  8. tsook

    tsook Well-Known Member

    Joined:
    Mar 21, 2003
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    6
    You can solve this problem with ./easyapache (reinstall).
     
  9. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India

    Dd you enable gd on your system?. You can verify it, with the help of a phpinfo.php file. If Gd is not installed on your system , you should re-compile apache with 6 option.

    This command will help you to recompile apache
    ====================================
    /scripts/easyapache
    ====================================

    But you should take back up of your apache folder [/usr/local/apache/ or libexec and httpd.conf ] before doing it..

    If you install gd on your system, please check the following entries in your httpd config file.
    ==========================================
    LoadModule php4_module libexec/libphp4.so
    ----------------------------------------------------------
    AddModule mod_php4.c
    ==========================================

    If it is commented, commend out first and restart httpd.

    May be it will help you to solve this issue.
     
  10. tsook

    tsook Well-Known Member

    Joined:
    Mar 21, 2003
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    6
    GD was always installed on machine. But then suddenly stoped working (not GD, just crond when calling commancs with php and wget), for reason unknown to me. Reinstall solved problem.

    Yes, you must uncomment those two lines, and then restart.
     
Loading...

Share This Page