The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Php Help Asap

Discussion in 'General Discussion' started by talty, May 9, 2004.

  1. talty

    talty Registered

    Joined:
    Feb 28, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Here is what is happing. Everytime i try to access a php file on my server i get a box that pops up asking me to download that file my guess is php is not installed so i went into ssh and recompled it with php and everything and it still happens what do i do
     
  2. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    Your provider has phpsuexec installed and your files aren't compatible. Either have them turn it off or adjust your php files. Either way you need to contact your webhost.
     
  3. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
    Have you tried loading a page like phpinfo?

    <?php
    phpinfo();
    ?>

    Check your httpd.conf file for a line that reads:

    AddType application/x-httpd-php .php
     
  4. anor

    anor Registered

    Joined:
    Mar 30, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I also suffer this same problem as said above, however when i rebuild apached ( WHITOUT) php suexec apache won't start. It give me errors in my error_log:

    [Wed May 12 17:25:00 2004] [error] System: No such file or directory (errno: 2)
    [Wed May 12 17:25:26 2004] [notice] caught SIGTERM, shutting down
    [Wed May 12 17:25:29 2004] [warn] NameVirtualHost 65.someip:80 has no VirtualHosts
    [Wed May 12 17:25:29 2004] [warn] NameVirtualHost 65.someip:80 has no VirtualHosts
    [Wed May 12 17:25:29 2004] [notice] Apache/1.3.29 (Unix) mod_gzip/1.3.26.1a mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 FrontPage/5.0.2.2634 mod_ssl/2.8.16 OpenSSL/0.9.7a configured -- resuming normal operations
    [Wed May 12 17:25:29 2004] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    [Wed May 12 17:25:29 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)
    [Wed May 12 17:25:43 2004] [warn] child process 29527 still did not exit, sending a SIGTERM
    [Wed May 12 17:25:43 2004] [warn] child process 29528 still did not exit, sending a SIGTERM
    [Wed May 12 17:25:44 2004] [warn] NameVirtualHost 65.someip:80 has no VirtualHosts
    [Wed May 12 17:25:44 2004] [warn] NameVirtualHost 65.someip:80 has no VirtualHosts
    [Wed May 12 17:25:44 2004] [warn] pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Wed May 12 17:25:44 2004] [notice] Apache/1.3.29 (Unix) mod_gzip/1.3.26.1a mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 FrontPage/5.0.2.2634 mod_ssl/2.8.16 OpenSSL/0.9.7a configured -- resuming normal operations
    [Wed May 12 17:25:44 2004] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    [Wed May 12 17:25:44 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)

    I have tried too upgrade multiple times and trying mutliple settings but always either of the 2 results.
     
Loading...

Share This Page