The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

php.ini and zend optimizer

Discussion in 'General Discussion' started by hikaro, Apr 12, 2007.

  1. hikaro

    hikaro Well-Known Member

    Joined:
    Nov 22, 2005
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    16
    hello,

    i got problem here, i installed phpsuexec and zend optimizer, and i have 1 script that need zend active and register_globals active, so i place php.ini inside my public_html with code
    then put all the scripts inside, but i found that the script not work, it says
    Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in

    when i remove the php.ini, everything just going fine exept some script not working due to register_globals disable.

    anyone know where is the problem ? i have double checked all the settings and everything should be fine.
    here is my php -v output

    PHP 4.4.4 (cli) (built: Jan 14 2007 09:10:48)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    with the ionCube PHP Loader v3.1.24, Copyright (c) 2002-2006, by ionCube Ltd., and
    with Zend Extension Manager v1.0.10, Copyright (c) 2003-2006, by Zend Technologies
    with Zend Optimizer v3.0.1, Copyright (c) 1998-2006, by Zend Technologies


    Thank you
     
  2. support

    support Active Member

    Joined:
    Aug 30, 2003
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    Register Global

    Put register global on in the .htaccess file for the domain under which you are running the script instead of register global

    That should solved the issue
     
  3. hikaro

    hikaro Well-Known Member

    Joined:
    Nov 22, 2005
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    16
    hello,


    as i mentioned above that i run phpsuexec so it wont read any php value in .htaccess
    btw thank you
     
  4. yapluka

    yapluka Well-Known Member

    Joined:
    Dec 24, 2003
    Messages:
    301
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    France
    cPanel Access Level:
    Root Administrator
    Try :

    Code:
    register_globals = On
    ;)
     
  5. hikaro

    hikaro Well-Known Member

    Joined:
    Nov 22, 2005
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    16
    got the solution, i just put the zend extension code into user's php.ini and it works fine.
    thank you for your help.
     
Loading...

Share This Page